This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: Python 3.0b3 - Idle doesn't start on win XPh
Type: crash Stage:
Components: IDLE Versions: Python 3.0
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE does not run with Py30b3
View: 3628
Assigned To: Nosy List: loewis, tjd, vbr
Priority: normal Keywords:

Created on 2008-09-09 11:28 by vbr, last changed 2022-04-11 14:56 by admin. This issue is now closed.

Messages (4)
msg72843 - (view) Author: Vlastimil Brom (vbr) Date: 2008-09-09 11:28
Using Python 3.0b3 on windows XPH SP2 (installed form python-3.0b3.msi) 
Idle can't be started.
Using a windows shortcut, only an error-promt is shown "Subprocess 
Startup Error: IDLE's subprocess dien't make connection. Either IDLE 
can't start a subprocess or personal firewall is blocking the 
I'm aware of the warning about firewalls in IDLE, but the previous 3.0 
betas didn't have that issue with the same settings of the windows 

After directly calling:
C:\Python30\python.exe C:\Python30\Lib\idlelib\

The same error is thrown, but previously another exception is writen to 
the console:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "C:\Python30\lib\idlelib\", line 76, in main
AttributeError: 'Thread' object has no attribute 'set_daemon'

msg72881 - (view) Author: Toby Donaldson (tjd) Date: 2008-09-09 16:19
I also had problems running IDLE, and the fix listed here solved it for
msg72887 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-09-09 17:43
Closing as a duplicate of issue3628
msg72895 - (view) Author: Vlastimil Brom (vbr) Date: 2008-09-09 19:08
Sorry for the noise, somehow my search in the bug tracker didn't show 
this report; after fixing the mentioned line in everything works 
Date User Action Args
2022-04-11 14:56:38adminsetgithub: 48065
2008-09-09 19:08:40vbrsetmessages: + msg72895
2008-09-09 17:43:07loewissetstatus: open -> closed
resolution: duplicate
superseder: IDLE does not run with Py30b3
messages: + msg72887
nosy: + loewis
2008-09-09 16:19:14tjdsetnosy: + tjd
messages: + msg72881
2008-09-09 11:28:36vbrcreate