classification
Title: zip() docstring should say 'iterator' instead of 'object with __next__()'
Type: behavior Stage: resolved
Components: Documentation Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, rhettinger, sir-sigurd
Priority: normal Keywords:

Created on 2019-08-29 03:30 by sir-sigurd, last changed 2019-08-29 07:10 by rhettinger. This issue is now closed.

Messages (2)
msg350704 - (view) Author: Sergey Fedoseev (sir-sigurd) * Date: 2019-08-29 03:30
In [3]: help(zip)

class zip(object)
 |  zip(*iterables) --> zip object
 |  
 |  Return a zip object whose .__next__() method returns a tuple where
 |  the i-th element comes from the i-th iterable argument.  The .__next__()
 |  method continues until the shortest iterable in the argument sequence
 |  is exhausted and then it raises StopIteration.

This description is awkward and should use term 'iterator' as https://docs.python.org/3/library/functions.html#zip does.

The same applies to chain(), count() and zip_longest() from itertools.
msg350741 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2019-08-29 07:10
This looks fine to me.
History
Date User Action Args
2019-08-29 07:10:10rhettingersetstatus: open -> closed
resolution: not a bug
messages: + msg350741

stage: resolved
2019-08-29 07:06:34xtreaksetnosy: + rhettinger
type: behavior
2019-08-29 03:30:45sir-sigurdcreate