classification
Title: Doesn't delete PATH from System Variables (uninstallation)
Type: behavior Stage: resolved
Components: Windows Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Uninstalling Py352 x86 with /uninstall option does not remove prepended paths
View: 28576
Assigned To: Nosy List: Paul Francis, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2019-08-07 14:23 by Paul Francis, last changed 2019-08-08 16:20 by steve.dower. This issue is now closed.

Messages (4)
msg349167 - (view) Author: Paul Francis (Paul Francis) Date: 2019-08-07 14:23
Neither the 32bit nor the 64bit version of Python 3.7.4 will remove the PATH variables from the System Environment Variables of the O/S even though the uninstallation screen explicitly displays a message that infers it is doing so.

Windows 10 Pro x64 v1903
msg349176 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-08-07 17:07
Duplicate of issue28576
msg349209 - (view) Author: Paul Francis (Paul Francis) Date: 2019-08-08 03:46
This is regarding the GUI uninstall program that is accessedd via Programs & Features (formerly known as Add/Remove Programs) in Control Panel. Sorry I didn't make this clear.

That "duplicate" report seems to be for a Command Line method of uninstalling the program.
msg349240 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-08-08 16:20
There's no difference in the implementation between them, so unless you see that the command line approach works but the GUI does not, they are going to be exactly the same bug (and probably against either Windows or Wix, rather than CPython, but I haven't dug deep enough to be sure).
History
Date User Action Args
2019-08-08 16:20:17steve.dowersetstatus: open -> closed
resolution: duplicate
messages: + msg349240
2019-08-08 03:47:36Paul Francissetstatus: closed -> open
resolution: duplicate -> (no value)
2019-08-08 03:46:21Paul Francissetmessages: + msg349209
2019-08-07 17:07:14steve.dowersetstatus: open -> closed
superseder: Uninstalling Py352 x86 with /uninstall option does not remove prepended paths
messages: + msg349176

resolution: duplicate
stage: resolved
2019-08-07 14:23:59Paul Franciscreate