classification
Title: Error 0x80070643 when installing
Type: behavior Stage:
Components: Installation, Windows Versions: Python 3.7
process
Status: open Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: bfbfbfb bfbfbf, eryksun, paul.moore, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2019-08-04 15:22 by bfbfbfb bfbfbf, last changed 2019-08-10 23:17 by terry.reedy.

Files
File name Uploaded Description Edit
Python 3.7.4 (32-bit)_20190804181255.log bfbfbfb bfbfbf, 2019-08-04 15:22 logs
Messages (5)
msg348988 - (view) Author: bfbfbfb bfbfbf (bfbfbfb bfbfbf) * Date: 2019-08-04 15:22
When installing python 3.7.4 64bit an error occurs 0x80070643, win10
msg349336 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2019-08-10 07:58
The error comes from Windows and it indicates a problem with your computer.  Questions about Windows errors should be initially directed to python-list or elsewhere.

Searching for 0x80070643 returns multiple hits, including this 'official' one.
https://answers.microsoft.com/en-us/insider/forum/all/windows-update-error-0x80070643/3bad0495-dabb-4e3f-91a7-aaf992ef537a
You could also search stackoverflow.com.
msg349340 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2019-08-10 13:09
If we see 0x8XXX_XXXX, it's either an NTSTATUS [1] warning, which is unlikely, or and HRESULT [2] error, which is very likely. One of the more common facility codes for HRESULT is the Windows API, 0x007. If we see 0x8007XXXX, then XXXX is a Windows system error code [3]. In this case, 0x643 is ERROR_INSTALL_FAILURE (1603), which is not a very information error code by itself. 

We need to read the log file (or request additional logs) to figure out what failed. Steve Dower is the person to address this, since he has far more experience with the design and behavior of the installer. From what I can see on the surface, with my shallow knowledge, it failed to install core_JustForMe for some reason (probably there's more info in another log), and then failed to delete the cached package when rolling back, with the error 0x80070003 (ERROR_PATH_NOT_FOUND), which looks suspicious.

I'm reopening for now. Feel free to close it again if you disagree. I won't press the matter.

[1] https://docs.microsoft.com/en-us/openspecs/windows_protocols/ms-erref/87fba13e-bf06-450e-83b1-9241dc81e781
[2] https://docs.microsoft.com/en-us/openspecs/windows_protocols/ms-erref/0642cb2f-2075-4469-918c-4441e69c548a
[3] https://docs.microsoft.com/en-us/windows/win32/debug/system-error-codes
msg349355 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-08-10 20:19
I can't see anything specific in that log file, but if you can provide the "Python 3.7.4 (32-bit)_20190804181255_000_core_JustForMe.log" file, that should be able to help.

(For others who may have to triage these in the future, the main thing you'll find in this log file is when the installer is attempting to upgrade from an AllUsers install to a JustForMe install, which almost always fails. But since this is upgrading from a previous JustForMe, it's not that.)
msg349364 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2019-08-10 23:17
I seems to me that Python Setup and Usage, Using Python on Windows should have a section for install failure and MS 0x8XXXXXXX install errors.  Then I and others on python-list could tell people to start with that.
History
Date User Action Args
2019-08-10 23:17:06terry.reedysetmessages: + msg349364
2019-08-10 20:19:29steve.dowersetmessages: + msg349355
2019-08-10 13:09:42eryksunsetstatus: closed -> open

nosy: + eryksun
messages: + msg349340

resolution: not a bug ->
stage: resolved ->
2019-08-10 07:58:45terry.reedysetstatus: open -> closed

type: crash -> behavior

nosy: + terry.reedy
messages: + msg349336
resolution: not a bug
stage: resolved
2019-08-04 15:30:25xtreaksetnosy: + paul.moore, tim.golden, zach.ware, steve.dower
components: + Windows
2019-08-04 15:22:58bfbfbfb bfbfbfcreate