classification
Title: Description of UserDict is misleading
Type: Stage: resolved
Components: Documentation Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, donovick, rhettinger
Priority: normal Keywords:

Created on 2019-07-24 18:03 by donovick, last changed 2019-07-25 01:02 by rhettinger. This issue is now closed.

Messages (2)
msg348393 - (view) Author: Caleb Donovick (donovick) * Date: 2019-07-24 18:03
The documentation for collections.UserDict states "In addition to supporting the methods and operations of mappings, UserDict instances provide the following attribute:  ..."

This however is misleading as it supports the operations of mutable mappings. Which is not stated anywhere.
msg348423 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2019-07-25 01:02
The term "mapping" is in lowercase and refers to the generic concept of a mapping as defined in the glossary.  This is distinct from the capital letter classes "Mapping" and "MutableMapping" as provided in the collections.abc module.  It is the former meaning that is intended.

Thank you for the suggestion.
History
Date User Action Args
2019-07-25 01:02:17rhettingersetstatus: open -> closed
resolution: not a bug
messages: + msg348423

stage: resolved
2019-07-24 18:05:22xtreaksetnosy: + rhettinger
2019-07-24 18:03:21donovickcreate