classification
Title: ERROR: grip 4.5.2 requires docopt>=0.4.0, which is not installed.
Type: behavior Stage: resolved
Components: Installation, macOS Versions: Python 3.8
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: Dima.Tisnek, ned.deily, ronaldoussoren, xtreak
Priority: normal Keywords:

Created on 2019-07-23 04:43 by Dima.Tisnek, last changed 2019-09-18 01:14 by Dima.Tisnek. This issue is now closed.

Messages (5)
msg348316 - (view) Author: Dima Tisnek (Dima.Tisnek) * Date: 2019-07-23 04:43
I have Python-3.7.2 installed.
I've just installed Python3.8.0b2 on macOS,
and ran "Install Certificates.command".
The terminal output contained:

ERROR: grip 4.5.2 requires docopt>=0.4.0, which is not installed.

(certifi-2019.6.16 got installed correctly)
(Re-running the command again doesn't produce same output, because certifi is up to date)
msg348320 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-07-23 05:27
grip and docopt are not a part of standard library. I assume this issue is related to Mac OS installer and tagging it as Mac OS issue for confirmation to close it as third party issue.
msg348335 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2019-07-23 14:46
Sorry, I have no idea why you saw those messages. Neither grip nor docopt are used directly by the python.org macOS installer and, after a quick glance, I didn't see anywhere where the certifi package used them.  Did you have an earlier alpha or beta version of 3.8.0 installed along with third-party packages (via python3.8 -m pip install, for example)?  Unless you can show how to reproduce this behavior, there is little we can do about it.
msg352683 - (view) Author: Dima Tisnek (Dima.Tisnek) * Date: 2019-09-18 01:03
I've just got it again, when running `Install Certificates.command` after installing Python 3.8.0b4.

Yes I do have Python 3.7 installed and had earlier 3.8 builds installed.

Could it be referenced by `pip`? Or `certifi` itself? I can't find any references...

I can reproduce this at will with:
`python -E -s -m pip install --upgrade certifi --force`

The `-E -s -m pip` is taken from the cert script, and `--force` is added so that pip doesn't short circuit.

Could it be that `grip` is installed badly and that even with `-E -s` it's somehow loaded?
msg352684 - (view) Author: Dima Tisnek (Dima.Tisnek) * Date: 2019-09-18 01:14
I've nuked 3.8/.../site-packages and the problem is gone; confirmed by reinstalling 3.8 from scratch.

It must've been something in the my environment, if/when I find what it was, I'll open a bug in the respective package.
History
Date User Action Args
2019-09-18 01:14:34Dima.Tisneksetstatus: open -> closed

messages: + msg352684
stage: resolved
2019-09-18 01:03:18Dima.Tisneksetstatus: pending -> open

messages: + msg352683
2019-07-23 14:46:03ned.deilysetstatus: open -> pending

messages: + msg348335
2019-07-23 05:27:17xtreaksetnosy: + xtreak, ronaldoussoren, ned.deily
messages: + msg348320

components: + macOS
type: behavior
2019-07-23 04:43:46Dima.Tisnekcreate