classification
Title: Documentation:conflict between docs
Type: Stage: resolved
Components: Documentation Versions: Python 3.7, Python 3.6, Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, methane, shiyuchong, yselivanov
Priority: normal Keywords:

Created on 2019-07-19 03:39 by shiyuchong, last changed 2020-04-23 06:05 by methane. This issue is now closed.

Messages (3)
msg348141 - (view) Author: 徐靖 (shiyuchong) Date: 2019-07-19 03:43
In https://docs.python.org/3/whatsnew/3.4.html#api-and-feature-removals,It is said "inspect.Signature: positional-only parameters are now required to have a valid name." 
But in https://docs.python.org/3/library/inspect.html?highlight=3.4#inspect.Signature, the actual change happened in inspect.Parameter, " Changed in version 3.4: In Python 3.3 Parameter objects were allowed to have name set to None if their kind was set to POSITIONAL_ONLY. This is no longer permitted."
So I wonder is it a mistake?
msg348142 - (view) Author: Inada Naoki (methane) * (Python committer) Date: 2019-07-19 05:59
https://docs.python.org/3/library/inspect.html#inspect.Parameter.replace

"""
Changed in version 3.4: In Python 3.3 Parameter objects were allowed to have name set to None if their kind was set to POSITIONAL_ONLY. This is no longer permitted.
"""
msg367082 - (view) Author: Inada Naoki (methane) * (Python committer) Date: 2020-04-23 06:05
I don't think they are conflict.

"now required to have a valid name."
"were allowed to have name set to None [snip]  This is no longer permitted."

"None" is not "valid name".
History
Date User Action Args
2020-04-23 06:05:52methanesetstatus: open -> closed
resolution: not a bug
messages: + msg367082

stage: resolved
2019-07-19 05:59:47methanesetnosy: + methane
messages: + msg348142
2019-07-19 05:46:53SilentGhostsetnosy: + yselivanov
2019-07-19 03:43:42shiyuchongsetmessages: + msg348141
2019-07-19 03:39:04shiyuchongcreate