classification
Title: [3.10 prep] site.py uses `sys.version[:3]`
Type: Stage: resolved
Components: Versions: Python 3.9
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: Anthony Sottile
Priority: normal Keywords:

Created on 2019-07-18 06:41 by Anthony Sottile, last changed 2019-07-18 18:13 by brett.cannon. This issue is now closed.

Messages (2)
msg348101 - (view) Author: Anthony Sottile (Anthony Sottile) * Date: 2019-07-18 06:41
In an effort to try and fix some of the ecosystem before python3.10 (or 4.0) is a thing, I figured I'd set up a build where the version is bumped and see what's broken.

If you're interested in reproducing my findings, I've included a build that's installable in ubuntu in this PPA: https://launchpad.net/~asottile/+archive/ubuntu/python3.10

It's mostly based on this patch: https://github.com/asottile/python3.10/blob/ubuntu/bionic/debian/patches/0029-pretend-3.10.patch

while tracking down why pip doesn't work, I've encountered the following from doing this:

$ python3.10 -c 'import sys; print(sys.path)'
['', '/usr/lib/python31.zip', '/usr/lib/python3.10', '/usr/lib/python3.10/lib-dynload', '/usr/lib/python3/dist-packages']


this notably is missing the versioned site-packages / dist-packages directory
msg348102 - (view) Author: Anthony Sottile (Anthony Sottile) * Date: 2019-07-18 06:42
disregard, this appears to be due to debian's patching
History
Date User Action Args
2019-07-18 18:13:37brett.cannonsetresolution: third party
2019-07-18 06:42:33Anthony Sottilesetstatus: open -> closed

messages: + msg348102
stage: resolved
2019-07-18 06:41:34Anthony Sottilecreate