classification
Title: Improve test_dtrace.py
Type: Stage: resolved
Components: Tests Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: shihai1991, xiang.zhang
Priority: normal Keywords: patch

Created on 2019-07-16 16:23 by shihai1991, last changed 2019-07-16 17:35 by shihai1991. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 14796 closed shihai1991, 2019-07-16 16:28
Messages (4)
msg348029 - (view) Author: Hai Shi (shihai1991) * (Python triager) Date: 2019-07-16 16:23
$ ./python -m unittest test.test_dtrace
ssssE
======================================================================
ERROR: setUpClass (test.test_dtrace.TraceTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/shihai/workspace/cpython/Lib/test/test_dtrace.py", line 110, in setUpClass
    self.backend.assert_usable()
AttributeError: 'NoneType' object has no attribute 'assert_usable'

----------------------------------------------------------------------
Ran 0 tests in 0.008s

FAILED (errors=1, skipped=4)
msg348030 - (view) Author: Hai Shi (shihai1991) * (Python triager) Date: 2019-07-16 16:26
Looks backend should be estimated before running unit tests.
msg348031 - (view) Author: Xiang Zhang (xiang.zhang) * (Python committer) Date: 2019-07-16 16:52
In Py3, you should use `python -m test test_dtrace` to run the test suite.
msg348035 - (view) Author: Hai Shi (shihai1991) * (Python triager) Date: 2019-07-16 17:35
Thanks, copy that.
History
Date User Action Args
2019-07-16 17:35:21shihai1991setmessages: + msg348035
2019-07-16 16:53:15xiang.zhangsetversions: - Python 3.5
2019-07-16 16:52:53xiang.zhangsetstatus: open -> closed

versions: + Python 3.5
nosy: + xiang.zhang

messages: + msg348031
resolution: not a bug
stage: patch review -> resolved
2019-07-16 16:28:17shihai1991setkeywords: + patch
stage: patch review
pull_requests: + pull_request14592
2019-07-16 16:26:27shihai1991setmessages: + msg348030
2019-07-16 16:23:04shihai1991create