classification
Title: asyncio: freeze when using MultiLoopChildWatcher on Solaris
Type: Stage: resolved
Components: asyncio, Library (Lib) Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: asyncio: MultiLoopWatcher has a race condition (test_asyncio: test_close_kill_running() hangs on AMD64 RHEL7 Refleaks 3.x)
View: 38323
Assigned To: asvetlov Nosy List: asvetlov, chris.jerdonek, kulikjak, yselivanov
Priority: normal Keywords:

Created on 2019-07-12 12:57 by kulikjak, last changed 2020-05-14 15:56 by kulikjak. This issue is now closed.

Messages (5)
msg347743 - (view) Author: Jakub Kulik (kulikjak) * Date: 2019-07-12 12:57
Hi,

since the 3.8.0b2 test_asyncio freezes in test_subprocess when MultiLoopChildWatcher is being used as a watcher (new in b2). All other watchers are working as expected. This is all on Solaris.

I tried to find out the reason for these issues and it seems that awaited coroutines never end (there are many tests with this problem - I tested it on test_cancel_make_subprocess_transport_exec). I found out that commenting out `signal.siginterrupt(signal.SIGCHLD, False)` in `attach_loop` method of MultiLoopChildWatcher seems to fix the issue, however, I don't understand this enough to see why that should be a problem...

I can provide more information if necessary.
msg347843 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2019-07-13 16:27
Thanks for the report.
msg368522 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2020-05-09 14:25
This looks like a duplicate of #38323: https://bugs.python.org/issue38323
msg368726 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2020-05-12 11:40
Closing as a duplicate of #38323: https://bugs.python.org/issue38323
msg368844 - (view) Author: Jakub Kulik (kulikjak) * Date: 2020-05-14 15:56
You are right, that seems to be the same issue. Thanks for closing this.
History
Date User Action Args
2020-05-14 15:56:05kulikjaksetmessages: + msg368844
2020-05-12 11:40:40chris.jerdoneksetresolution: duplicate
2020-05-12 11:40:32chris.jerdoneksetstatus: open -> closed
superseder: asyncio: MultiLoopWatcher has a race condition (test_asyncio: test_close_kill_running() hangs on AMD64 RHEL7 Refleaks 3.x)
messages: + msg368726

stage: resolved
2020-05-09 14:25:38chris.jerdoneksetnosy: + chris.jerdonek
messages: + msg368522
2019-07-13 16:27:16asvetlovsetassignee: asvetlov
messages: + msg347843
2019-07-12 13:08:57xtreaksetnosy: + yselivanov, asvetlov
components: + asyncio
2019-07-12 12:57:35kulikjakcreate