classification
Title: test_multiprocessing fails on AMD64 FreeBSD CURRENT Shared 2.7
Type: Stage: resolved
Components: Tests Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Add method send_io, recv_io to the socket module.
View: 28724
Assigned To: Nosy List: nanjekyejoannah, pablogsal, vstinner
Priority: normal Keywords:

Created on 2019-06-24 11:28 by vstinner, last changed 2019-08-28 23:46 by vstinner. This issue is now closed.

Messages (3)
msg346378 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-06-24 11:28
AMD64 FreeBSD CURRENT Shared 2.7:
https://buildbot.python.org/all/#/builders/169/builds/146

0:02:22 load avg: 3.64 [119/404/1] test_multiprocessing failed
Process Process-16:
Traceback (most recent call last):
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/process.py", line 267, in _bootstrap
    self.run()
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/process.py", line 114, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/test/test_multiprocessing.py", line 1797, in _writefd
    fd = reduction.recv_handle(conn)
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/reduction.py", line 83, in recv_handle
    return _multiprocessing.recvfd(conn.fileno())
RuntimeError: No file descriptor received
Process Process-17:
Traceback (most recent call last):
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/process.py", line 267, in _bootstrap
    self.run()
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/process.py", line 114, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/test/test_multiprocessing.py", line 1797, in _writefd
    fd = reduction.recv_handle(conn)
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/reduction.py", line 83, in recv_handle
    return _multiprocessing.recvfd(conn.fileno())
RuntimeError: No file descriptor received
test test_multiprocessing failed -- multiple errors occurred; run in verbose mode for details

...

test_duplex_false (test.test_multiprocessing.WithProcessesTestConnection) ... ok
Process Process-16:
Traceback (most recent call last):
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/process.py", line 267, in _bootstrap
    self.run()
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/process.py", line 114, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/test/test_multiprocessing.py", line 1797, in _writefd
    fd = reduction.recv_handle(conn)
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/reduction.py", line 83, in recv_handle
    return _multiprocessing.recvfd(conn.fileno())
RuntimeError: No file descriptor received
test_fd_transfer (test.test_multiprocessing.WithProcessesTestConnection) ... FAIL
Process Process-17:
Traceback (most recent call last):
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/process.py", line 267, in _bootstrap
    self.run()
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/process.py", line 114, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/test/test_multiprocessing.py", line 1797, in _writefd
    fd = reduction.recv_handle(conn)
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/multiprocessing/reduction.py", line 83, in recv_handle
    return _multiprocessing.recvfd(conn.fileno())
RuntimeError: No file descriptor received
test_large_fd_transfer (test.test_multiprocessing.WithProcessesTestConnection) ... FAIL

======================================================================
FAIL: test_fd_transfer (test.test_multiprocessing.WithProcessesTestConnection)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/test/test_multiprocessing.py", line 1819, in test_fd_transfer
    self.assertEqual(f.read(), b"foo")
AssertionError: '' != 'foo'

======================================================================
FAIL: test_large_fd_transfer (test.test_multiprocessing.WithProcessesTestConnection)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/2.7.koobs-freebsd-current/build/Lib/test/test_multiprocessing.py", line 1851, in test_large_fd_transfer
    self.assertEqual(f.read(), b"bar")
AssertionError: '' != 'bar'

----------------------------------------------------------------------
msg346380 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-06-24 11:29
See also bpo-28724: Add method send_io, recv_io to the socket module.
msg350696 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-08-28 23:46
AMD64 FreeBSD CURRENT Shared 2.7 is back to green: this issue is a duplicate of bpo-28724 that I fixed recently.
History
Date User Action Args
2019-08-28 23:46:16vstinnersetstatus: open -> closed
superseder: Add method send_io, recv_io to the socket module.
messages: + msg350696

resolution: duplicate
stage: resolved
2019-06-24 11:29:49vstinnersetnosy: + pablogsal, nanjekyejoannah
messages: + msg346380
2019-06-24 11:28:39vstinnercreate