classification
Title: AF_UNIX should be supported on Windows
Type: enhancement Stage: resolved
Components: Windows Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Paul Monson, ZackerySpytz, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords: patch

Created on 2019-06-22 00:58 by Paul Monson, last changed 2019-06-24 20:12 by Paul Monson. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 14302 closed Paul Monson, 2019-06-22 01:02
Messages (3)
msg346266 - (view) Author: Paul Monson (Paul Monson) * Date: 2019-06-22 00:58
AF_UNIX has been supported on windows since version 1803 (build 17134)
see https://devblogs.microsoft.com/commandline/af_unix-comes-to-windows/

Enabling support for AF_UNIX will enable better peer-to-peer connectivity scenarios for Azure IoT Edge.  The changes to enable AF_UNIX on Windows seem small and low risk.

I need feedback on these proposed changes
msg346279 - (view) Author: Zackery Spytz (ZackerySpytz) * (Python triager) Date: 2019-06-22 13:23
This is a duplicate of bpo-33408.
msg346439 - (view) Author: Paul Monson (Paul Monson) * Date: 2019-06-24 20:12
Thanks Zackery.  Closing as duplicate
History
Date User Action Args
2019-06-24 20:12:43Paul Monsonsetstatus: open -> closed
resolution: duplicate
messages: + msg346439

stage: patch review -> resolved
2019-06-22 13:23:27ZackerySpytzsetnosy: + ZackerySpytz
messages: + msg346279
2019-06-22 01:02:44Paul Monsonsetkeywords: + patch
stage: patch review
pull_requests: + pull_request14126
2019-06-22 00:58:50Paul Monsoncreate