classification
Title: Pasting emoji crashes IDLE
Type: crash Stage: resolved
Components: IDLE Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE 3.x on Windows exits when pasting non-BMP unicode
View: 13153
Assigned To: terry.reedy Nosy List: md37, terry.reedy, xtreak
Priority: normal Keywords:

Created on 2019-06-14 18:53 by md37, last changed 2019-06-14 20:49 by terry.reedy. This issue is now closed.

Messages (3)
msg345630 - (view) Author: Miłosz (md37) Date: 2019-06-14 18:53
On Windows 10
msg345634 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python triager) Date: 2019-06-14 19:32
Can you please add a traceback if any? See also https://bugs.python.org/issue13153
msg345637 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2019-06-14 20:49
In the absence of evidence otherwise (the string that you pasted and the full traceback), I assume that you pasted a non-BMP codepoint, making this a duplicate of #13153.  If you think otherwise, please supply more info.
History
Date User Action Args
2019-06-14 20:49:37terry.reedysetstatus: open -> closed
superseder: IDLE 3.x on Windows exits when pasting non-BMP unicode
messages: + msg345637

resolution: duplicate
stage: resolved
2019-06-14 19:32:58xtreaksetnosy: + xtreak
messages: + msg345634
2019-06-14 18:53:22md37create