classification
Title: [Idle-dev] Feedback appreciated for two suggested new features
Type: behavior Stage: resolved
Components: Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE: Search dialogs can be hidden behind the main window
View: 37177
Assigned To: Nosy List: IrvKalb, SilentGhost, taleinat
Priority: normal Keywords:

Created on 2019-06-07 16:26 by IrvKalb, last changed 2019-06-07 16:30 by SilentGhost. This issue is now closed.

Messages (2)
msg344963 - (view) Author: Irv Kalb (IrvKalb) Date: 2019-06-07 16:26
[I'm not sure of the proper protocol here, I hope sending a message this way is OK.]

Hi,

I am writing about the potential fix to the Search Dialog box problem in IDLE that I reported a while back.  I can see that there is a flurry of activity on this bug.  I saw that there was a code change, but since I have never looked at IDLE source code, I really cannot comment on the fix.

However, I did see comments that it might be difficult to reproduce, so I made a short video to clearly demonstrate the bug.  (This is on IDLE/Python 3.6.1 Mac)  You can see it here:

http://www.youtube.com/watch?v=YWDsOEN8qsE <http://www.youtube.com/watch?v=YWDsOEN8qsE>

I did not get a chance to test this out on Window, but the bug is easily reproducible on a Mac.

If the change is to leave the dialog box in front of the editing window, that would be be fine.  But long term, if it is possible to incorporate a search bar like the one in PyCharm, that would be even better.

Thanks for addressing the issue and I hope this video is helpful.

Irv

> On Jun 6, 2019, at 9:28 AM, Tal Einat <taleinat@gmail.com> wrote:
> 
> After a great delay, I've created an issue[0] about the search dialogs being hidden behind the main window, and have a PR[1] up with a proposed fix.
> 
> [0] https://bugs.python.org/issue37177 <https://bugs.python.org/issue37177>
> [1] https://github.com/python/cpython/pull/13869 <https://github.com/python/cpython/pull/13869>
> On Thu, Oct 18, 2018 at 8:13 PM Irv Kalb <Irv@furrypants.com <mailto:Irv@furrypants.com>> wrote:
> Hi,
> 
> I don't have a strong opinion about the details of the search and replace dialogs.  However, I can tell you that a change replacing the dialog box would be greatly appreciated.
> 
> I teach Python classes using IDLE.  The search dialog is a real a problem for new students and me as the teacher.  My students and I often get into a scenario where the search dialog gets hidden behind a editing window.  When that happens, then you try to make edits in code and nothing happens.  This happens to very often.  I have learned to look for the hidden search dialog window, but my students get very flustered.
> 
> I think that a search bar would be a great improvement.  If you can model it similar to the one in PyCharm, that would be wonderful.
> 
> Thanks for looking into this issue.
> 
> Irv
> 
> 
>> On Oct 13, 2018, at 2:51 PM, Tal Einat <taleinat@gmail.com <mailto:taleinat@gmail.com>> wrote:
>> 
>> Hi,
>> 
>> I've recently been working on two new features, for which I'd like to discuss whether it would be wise to include in IDLE. Each has a working implementation in a PR to make it easy to give it a try.
>> 
>> 1. Replace the search and replace dialogs with a search bar
>> https://bugs.python.org/issue34976 <https://bugs.python.org/issue34976>
>> https://github.com/python/cpython/pull/9855 <https://github.com/python/cpython/pull/9855>
>> 
>> 2. Ability to run 3rd party code checkers
>> https://bugs.python.org/issue21880 <https://bugs.python.org/issue21880>
>> https://github.com/python/cpython/pull/9802 <https://github.com/python/cpython/pull/9802>
>> 
>> Any thoughts would be greatly appreciated!
>> 
>> - Tal Einat
>> _______________________________________________
>> IDLE-dev mailing list
>> IDLE-dev@python.org <mailto:IDLE-dev@python.org>
>> https://mail.python.org/mailman/listinfo/idle-dev <https://mail.python.org/mailman/listinfo/idle-dev>
> 
> _______________________________________________
> IDLE-dev mailing list
> IDLE-dev@python.org <mailto:IDLE-dev@python.org>
> https://mail.python.org/mailman/listinfo/idle-dev <https://mail.python.org/mailman/listinfo/idle-dev>
msg344964 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2019-06-07 16:30
This seems to have been posted to bpo by mistake. I'm going to close this issue as a duplicate of #37177 and I would appreciate if you would send your e-mail to the idle-dev mailing list instead.
History
Date User Action Args
2019-06-07 16:30:38SilentGhostsetstatus: open -> closed

superseder: IDLE: Search dialogs can be hidden behind the main window
type: behavior

nosy: + SilentGhost
messages: + msg344964
resolution: duplicate
stage: resolved
2019-06-07 16:26:13IrvKalbcreate