classification
Title: Cannot read saved csv file in a single run
Type: enhancement Stage:
Components: IDLE Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, gpolo, paul
Priority: normal Keywords:

Created on 2008-08-25 21:38 by paul, last changed 2009-03-29 11:17 by gpolo. This issue is now closed.

Messages (5)
msg71958 - (view) Author: Rahul Ghosh (paul) Date: 2008-08-25 21:38
I am trying to save a csv file from a scope and then open it to post 
process the data.
The file is getting created currectly, but when it tries to open the 
csv file it complains about file not found. I am trying to do this in 
a single run. If I rerun the code again, the file open function works 
correctly.

It cannot see the newly created csv file till the python code stops 
and I rerun it. How can I refresh the directory on the fly so that the 
newly saved file is seen right away. I am on windows xp machine.

Appreciate your help.

Thanks.
msg71959 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-08-25 21:40
Are you closing the file before trying to read it?
msg71961 - (view) Author: Rahul Ghosh (paul) Date: 2008-08-25 21:45
I wrote a python GPIB command to the scope to export the waveform as a 
csv file. Then in another function I try to read this file that I just 
saved and it cannot find the file till I rerun.
msg71962 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-08-25 21:47
On Mon, Aug 25, 2008 at 4:45 PM, Rahul Ghosh <report@bugs.python.org> wrote:
>
> Rahul Ghosh <rahul.ghosh@gmail.com> added the comment:
>
> I wrote a python GPIB command to the scope to export the waveform as a
> csv file. Then in another function I try to read this file that I just
> saved and it cannot find the file till I rerun.

Can you paste some code that will reproduce the problem?
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue3681>
> _______________________________________
>

-- 
Cheers,
Benjamin Peterson
"There's no place like 127.0.0.1."
msg84374 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-03-29 11:17
Closing for lack of interest.

Rahul, the bug tracker is a place to provide help not to obtain help. So
if you still have the problem mentioned, consider posting to a proper
mail list and if you can confirm it is really a bug then create a new issue.
History
Date User Action Args
2009-03-29 11:17:25gpolosetstatus: open -> closed

nosy: + gpolo
messages: + msg84374

resolution: not a bug
2008-08-25 21:47:36benjamin.petersonsetmessages: + msg71962
2008-08-25 21:45:15paulsetmessages: + msg71961
2008-08-25 21:40:13benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg71959
2008-08-25 21:38:44paulcreate