classification
Title: pressing HOME key in IDLE editor ends IDLE
Type: crash Stage:
Components: IDLE Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, terry.reedy, tjd
Priority: normal Keywords:

Created on 2008-08-25 20:37 by tjd, last changed 2008-11-15 04:42 by terry.reedy. This issue is now closed.

Messages (6)
msg71953 - (view) Author: Toby Donaldson (tjd) Date: 2008-08-25 20:37
In IDLE 3.0b2, whenever I press the Home key in an IDLE editor window,
IDLE ends and all windows disappear.
msg71954 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-08-25 20:42
Well, 3.0b3 is out and many bugs may have been corrected.
Can you try with this newer version?
msg72166 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2008-08-29 22:05
Things like this tend to be system specific, and sometimes even machine
specific, so please include platform/os with reports, even I you do not
think it relevant.

In this case, Home works as it should on my WinXP 3.0b2
(which is fortunate since there is no b3 installer, and may not be).
msg72168 - (view) Author: Toby Donaldson (tjd) Date: 2008-08-29 22:20
I am using (x86) Python 3.0b2 on Windows XP Home Edition (SP 3) on an
AMD 64 X2 Dual Core Processor 6400+, 2.41 GHz, with 2 GB of RAM.

Just to be clear, its when I press HOME in the *editor* window when the
crash occurs. There's no problem if I press HOME in the shell window.

As soon as the 3.0b3 (or later) installer is released for Windows, I'll
check it out again.
msg72184 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2008-08-30 07:41
The only system difference is that I have an older Athlon cpu.
And I did try Home (key above End) in the editor window and it moves
cursor to beginning of line.  My options/configure/key bindings starts
beginning-of-line <Key-Home>.  So this might be a peculiar interaction
with your system.  In .a5, I had a crash problem (which someone else
reproduced) that disappeared in .b1 without anyone claiming to have done
anything to fix the problem, so it seems IDLE can a bit fragile.
msg72785 - (view) Author: Toby Donaldson (tjd) Date: 2008-09-08 18:16
The problem seems to have disappeared in the 3.0b3 Windows installer
version --- the Home key seems to work as it should.

(However, to get IDLE to run at all in 3.03b, I had to apply the fix
listed here: http://bugs.python.org/issue3628)
History
Date User Action Args
2008-11-15 04:42:41terry.reedysetstatus: open -> closed
resolution: fixed
2008-09-08 18:16:42tjdsetmessages: + msg72785
2008-08-30 07:41:35terry.reedysetmessages: + msg72184
2008-08-29 22:20:12tjdsetmessages: + msg72168
2008-08-29 22:05:18terry.reedysetnosy: + terry.reedy
messages: + msg72166
2008-08-25 20:42:02amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg71954
2008-08-25 20:37:16tjdcreate