classification
Title: Create test for fcntl.lockf()
Type: Stage: resolved
Components: Tests Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Add open_file_descriptor parameter to fcntl.lockf() (use the new F_OFD_SETLK flag)
View: 22367
Assigned To: Nosy List: christian.heimes, corona10, nanjekyejoannah, vstinner
Priority: normal Keywords: patch

Created on 2019-04-28 18:32 by nanjekyejoannah, last changed 2020-01-15 21:37 by vstinner. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 12999 closed nanjekyejoannah, 2019-04-28 18:34
Messages (6)
msg341031 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2019-04-28 18:32
We need to implement a test for fcntl.lockf().
msg341032 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2019-04-28 18:40
I have opened a PR with this test. If you think its great, we can use the same test to test posix.lock(). The one I have written in more detailed than the current test for posix.lock().
msg341034 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2019-04-28 19:23
I have opened a PR with this test. If you think its great, we can use the same test to test posix.lockf(). The one I have written in more detailed than the current test for posix.lockf().

Correcting the above  comment.
msg358342 - (view) Author: Dong-hee Na (corona10) * (Python committer) Date: 2019-12-13 16:42
@nanjekyejoannah

IMHO, tests were added through bpo-22367
I think that we can close this issue.
What do you think?
msg358344 - (view) Author: Joannah Nanjekye (nanjekyejoannah) * (Python committer) Date: 2019-12-13 17:33
@victor looks to be the author of the change the introduced the tests that can resolve this.

Victor, can we consider this closed. I have no problem closing the issue and the related PR.
msg360076 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-01-15 21:37
PR #17010 of bpo-22367 added tests for fcntl.lockf(). I close this PR as a duplicate of bpo-22367. Thanks @nanjekyejoannah anyway!
History
Date User Action Args
2020-01-15 21:37:57vstinnersetstatus: open -> closed
superseder: Add open_file_descriptor parameter to fcntl.lockf() (use the new F_OFD_SETLK flag)
messages: + msg360076

resolution: duplicate
stage: patch review -> resolved
2019-12-13 17:33:39nanjekyejoannahsetnosy: + vstinner
messages: + msg358344
2019-12-13 16:42:53corona10setnosy: + corona10
messages: + msg358342
2019-04-28 19:23:28nanjekyejoannahsetmessages: + msg341034
2019-04-28 18:40:42nanjekyejoannahsetmessages: + msg341032
2019-04-28 18:34:45nanjekyejoannahsetkeywords: + patch
stage: patch review
pull_requests: + pull_request12920
2019-04-28 18:32:58nanjekyejoannahcreate