classification
Title: test_posix.py fails due to unsupported RWF_HIPRI
Type: Stage: resolved
Components: Versions: Python 3.8, Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: jdemeyer, pablogsal
Priority: normal Keywords: patch

Created on 2019-04-10 10:28 by jdemeyer, last changed 2019-04-13 16:28 by pablogsal. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 12762 merged pablogsal, 2019-04-10 10:57
PR 12819 merged miss-islington, 2019-04-13 16:07
Messages (1)
msg339844 - (view) Author: Jeroen Demeyer (jdemeyer) * (Python triager) Date: 2019-04-10 10:28
On Linux with an old kernel:

0:03:59 load avg: 5.97 [300/420/1] test_posix failed -- running: test_tools (1 min 11 sec), test_concurrent_futures (2 min 42 sec)
test test_posix failed -- Traceback (most recent call last):
  File "/usr/local/src/sage-config/local/src/cpython/Lib/test/test_posix.py", line 311, in test_preadv_flags
    self.assertEqual(posix.preadv(fd, buf, 3, os.RWF_HIPRI), 10)
OSError: [Errno 95] Operation not supported

The problem is obvious: it's testing a flag which is not supported by this kernel. The fact that the macro RWF_HIPRI is defined (which is a compile-time condition) does not imply that the kernel actually supports it (which is a run-time condition).
History
Date User Action Args
2019-04-13 16:28:33pablogsalsetstatus: open -> closed
stage: patch review -> resolved
resolution: fixed
versions: + Python 3.7, Python 3.8
2019-04-13 16:07:18miss-islingtonsetpull_requests: + pull_request12744
2019-04-10 10:57:42pablogsalsetkeywords: + patch
stage: patch review
pull_requests: + pull_request12691
2019-04-10 10:28:27jdemeyercreate