classification
Title: readline module Crashs on OpenBSD/amd64
Type: crash Stage:
Components: Library (Lib) Versions: Python 3.0, Python 2.6, Python 2.5
process
Status: closed Resolution: accepted
Dependencies: Superseder:
Assigned To: gregory.p.smith Nosy List: gregory.p.smith, henry.precheur, rpetrov
Priority: release blocker Keywords: 64bit, easy, patch

Created on 2008-08-22 05:41 by henry.precheur, last changed 2008-09-06 21:56 by gregory.p.smith. This issue is now closed.

Files
File name Uploaded Description Edit
patch.configure.in henry.precheur, 2008-08-22 05:41 patch to apply on r65970
Messages (6)
msg71723 - (view) Author: Henry Precheur (henry.precheur) Date: 2008-08-22 05:41
$ python2.5                                                            
                 
Python 2.5.2 (r252:60911, Jun 16 2008, 15:20:47)                       
                 
[GCC 3.3.5 (propolice)] on openbsd4                                    
                 
Type "help", "copyright", "credits" or "license" for more information. 
                 
>>> def complete(text, state):                                         
                 
...     print 'complete %r %d' % (text, state)                         
                 
...     if text == 'i' and state == 0:                                 
                 
...         return 'import'                                            
                 
...     else:                                                          
                 
...         return None                                                
                 
...                                                                    
                 
>>> import readline; readline.parse_and_bind("tab: complete")
>>> readline.set_completer(complete)                                   
                                     
>>> i<TAB> # <TAB> is press the tab key                                
                 
complete 'i' 0                                                         
                 
complete 'i' 1                                                         
                 
Segmentation fault (core dumped)                                       
                 
                                                                       
                 
The problem is that Python is using a function present in libreadline  
                 
but not declared in readline/readline.h: completion_matches. Instead of
                 
using rl_completion_matches.                                           
                 
                                                                       
                 
Therefor the return type of completion_matches was an int which is     
                 
32bits on amd64 but the function was supposed to returns a pointer which
                
is 64 bits. So when the pointer had a "high" value, it was truncated.  
                 
                                                                       
                 
The problem is fixed by adding libcurses to AC_CHECK_LIB when checking
for functions in libreadline since libreadline depends on curses. This
makes Python use the correct functions declared on readline.h with a   
                       
correct return type.

Patch is attached.

(Others versions of Python should also be affected)
msg71724 - (view) Author: Henry Precheur (henry.precheur) Date: 2008-08-22 05:52
Looks like this patch should also be applied to python 2.6 & 3.

I did not tested but the patch is trivial enough to be applied without
too much fear of breaking something ;)
msg72375 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2008-09-03 05:59
committed to trunk (2.6) in r66179.  This should be back ported to 
release25-maint and automagically merged into py3k.

can someone with OpenBSD confirm that this has indeed fixed the problem?  
if so i'll do the 25 backport and mark it as closed instead of pending.
msg72465 - (view) Author: Henry Precheur (henry.precheur) Date: 2008-09-04 02:23
I just compiled the latest version of trunk. The problem seems to be
fixed. And according to config.log & nm, readline.so is linked with the
right function.
msg72538 - (view) Author: Roumen Petrov (rpetrov) * Date: 2008-09-04 22:43
may issue 1204 is more general
msg72710 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2008-09-06 21:56
true, issue 1204 is more general.  i'll leave this in but it can be
removed once the better general fix is in with 1204.  i won't backport
this one.
History
Date User Action Args
2008-09-06 21:56:41gregory.p.smithsetstatus: pending -> closed
keywords: + 64bit
messages: + msg72710
versions: + Python 2.6
2008-09-04 22:43:49rpetrovsetnosy: + rpetrov
messages: + msg72538
2008-09-04 02:23:57henry.precheursetmessages: + msg72465
2008-09-03 06:00:14gregory.p.smithsetkeywords: - needs review
2008-09-03 05:59:57gregory.p.smithsetstatus: open -> pending
versions: - Python 2.6
nosy: + gregory.p.smith
messages: + msg72375
assignee: gregory.p.smith
keywords: + easy
resolution: accepted
2008-08-22 09:38:00pitrousetpriority: release blocker
keywords: + patch, needs review
versions: + Python 2.6, Python 3.0
2008-08-22 05:52:46henry.precheursetmessages: + msg71724
2008-08-22 05:41:07henry.precheurcreate