classification
Title: '_io.TextIOWrapper' object has no attribute 'mode'
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.8, Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: File mode should be a constant
View: 32655
Assigned To: Nosy List: berker.peksag, nemeskeyd, pitrou
Priority: normal Keywords:

Created on 2019-03-12 14:30 by nemeskeyd, last changed 2019-05-30 23:07 by berker.peksag. This issue is now closed.

Messages (3)
msg337745 - (view) Author: Dávid Nemeskey (nemeskeyd) Date: 2019-03-12 14:30
TextIOWrapper objects returned by gzip.open() or bz2.open() do not have the 'mode' data member. Those returned by io.open() do. It would be nice if it did.
msg337746 - (view) Author: Dávid Nemeskey (nemeskeyd) Date: 2019-03-12 14:35
Note that this is not the same as GZipFile.mode, which is 1 or 2 (READ or WRITE), instead of the more informative "[raw][bt ]".
msg344011 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2019-05-30 23:07
Thank you for the report. This is a duplicate of issue 32655.
History
Date User Action Args
2019-05-30 23:07:47berker.peksagsetstatus: open -> closed

superseder: File mode should be a constant

nosy: + berker.peksag
messages: + msg344011
resolution: duplicate
stage: resolved
2019-03-13 10:27:42SilentGhostsetnosy: + pitrou

type: behavior
versions: + Python 3.8, - Python 3.5
2019-03-12 14:35:59nemeskeydsetmessages: + msg337746
2019-03-12 14:30:43nemeskeydcreate