classification
Title: Lock release fails under windows
Type: crash Stage: resolved
Components: Interpreter Core, Windows Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: concurrent.futures.ProcessPoolExecutor does not work in venv on Windows
View: 35797
Assigned To: Nosy List: Konrad Ciecierski, eryksun, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2019-03-08 20:04 by Konrad Ciecierski, last changed 2019-03-10 01:49 by eryksun. This issue is now closed.

Files
File name Uploaded Description Edit
multip-test.py Konrad Ciecierski, 2019-03-08 20:04 sample file for bug reproduction
Messages (3)
msg337527 - (view) Author: Konrad Ciecierski (Konrad Ciecierski) Date: 2019-03-08 20:04
In python 3.7.2 when the subprocess releases the acquired lock, 
the OSError occurs: "OSError: [WinError 6] The handle is invalid".
Problem does not occur under Ubuntu 18.

  File "multip-test.py", line 13, in worker
    lock.release()
OSError: [WinError 6] The handle is invalid
msg337553 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2019-03-09 03:52
If you're using a virtual environment, then this is most likely a duplicate of issue 35797.
msg337581 - (view) Author: Konrad Ciecierski (Konrad Ciecierski) Date: 2019-03-09 19:50
Yes, it is the same case.
Still, the current official (3.7.2) release is affected by this problem.
History
Date User Action Args
2019-03-10 01:49:48eryksunsetsuperseder: concurrent.futures.ProcessPoolExecutor does not work in venv on Windows
2019-03-09 19:50:28Konrad Ciecierskisetstatus: open -> closed
resolution: duplicate
messages: + msg337581

stage: resolved
2019-03-09 03:52:50eryksunsetnosy: + eryksun
messages: + msg337553
2019-03-08 20:04:20Konrad Ciecierskicreate