classification
Title: test_descr: test_vicious_descriptor_nonsense() fails randomly
Type: Stage: resolved
Components: Tests Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: pablogsal, serhiy.storchaka, vstinner
Priority: normal Keywords:

Created on 2019-02-25 21:45 by vstinner, last changed 2019-02-25 23:23 by pablogsal. This issue is now closed.

Messages (3)
msg336562 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-02-25 21:45
test_vicious_descriptor_nonsense() started to fails randomly:

$ ./python -m test -j0 -F test_descr test_descr test_descr test_descr test_descr test_descr
Run tests in parallel using 10 child processes
0:00:03 load avg: 1.24 [1/6] test_descr passed
0:00:03 load avg: 1.70 [2/6/1] test_descr failed
test test_descr failed -- Traceback (most recent call last):
  File "/home/vstinner/prog/python/master/Lib/test/test_descr.py", line 4341, in test_vicious_descriptor_nonsense
    self.assertEqual(c.attr, 1)
  File "/home/vstinner/prog/python/master/Lib/test/test_descr.py", line 4328, in __eq__
    del C.attr
AttributeError: attr
0:00:03 load avg: 1.70 [3/6/1] test_descr passed
0:00:04 load avg: 1.70 [4/6/1] test_descr passed
0:00:04 load avg: 1.70 [5/6/1] test_descr passed
0:00:04 load avg: 1.70 [6/6/1] test_descr passed

== Tests result: FAILURE ==

5 tests OK.

1 test failed:
    test_descr

Total duration: 4 sec 213 ms
Tests result: FAILURE

--

It seems like it's a regression introduced by this change:

a24107b04c1277e3c1105f98aff5bfa3a98b33a0 is the first bad commit
commit a24107b04c1277e3c1105f98aff5bfa3a98b33a0
Author: Serhiy Storchaka <storchaka@gmail.com>
Date:   Mon Feb 25 17:59:46 2019 +0200

    bpo-35459: Use PyDict_GetItemWithError() instead of PyDict_GetItem(). (GH-11112)

:040000 040000 da22597a443c84fb29588a3557f5dd04e292a1cc fb73df9fbfdc1893e9f0bde9fbc6ab6febabbe8f M	Include
:040000 040000 4b26a84a0e3a813470e34ddef29596da41d3d28f ca6192ea98e014434a32e2a114e42b297408ce00 M	Modules
:040000 040000 b2dd7d4e832c64ba44781a34093c5d69ea127932 26bfeced0b5776634051ed57d701361252c6de68 M	Objects
:040000 040000 6b5a0bf3a25434ee3de5c9dae3e880217773c0fb 56265d6d2cd8cb92ba47541909af2edec46196e6 M	Python
msg336575 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2019-02-25 23:23
Duplicate of https://bugs.python.org/issue36109
msg336576 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2019-02-25 23:23
I was faster this time ;)
History
Date User Action Args
2019-02-25 23:23:47pablogsalsetmessages: + msg336576
2019-02-25 23:23:25pablogsalsetstatus: open -> closed
resolution: duplicate
stage: resolved
2019-02-25 23:23:12pablogsalsetnosy: + pablogsal
messages: + msg336575
2019-02-25 21:45:42vstinnercreate