classification
Title: test_slice crashed on s390x Debian 3.x: gc_decref: Assertion "gc_get_refs(g) > 0" failed: refcount is too small
Type: Stage: resolved
Components: Interpreter Core Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_slice: gc_decref: Assertion "gc_get_refs(g) > 0" failed: refcount is too small
View: 35961
Assigned To: Nosy List: pablogsal, vstinner, xtreak
Priority: normal Keywords:

Created on 2019-02-12 16:27 by vstinner, last changed 2019-02-12 16:47 by vstinner. This issue is now closed.

Messages (5)
msg335320 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-02-12 16:27
s390x Debian 3.x:
https://buildbot.python.org/all/#/builders/13/builds/2344

0:06:26 load avg: 0.92 [291/420/1] test_slice crashed (Exit code -6)
Modules/gcmodule.c:110: gc_decref: Assertion "gc_get_refs(g) > 0" failed: refcount is too small
Enable tracemalloc to get the memory block allocation traceback

object  : <test.test_slice.SliceTest.test_cmp.<locals>.BadCmp object at 0x3ff93967e90>
type    : BadCmp
refcount: 1
address : 0x3ff93967e90
Fatal Python error: _PyObject_AssertFailed

Current thread 0x000003ff95272700 (most recent call first):
  File "/home/dje/cpython-buildarea/3.x.edelsohn-debian-z/build/Lib/test/test_slice.py", line 107 in <lambda>
  File "/home/dje/cpython-buildarea/3.x.edelsohn-debian-z/build/Lib/unittest/case.py", line 197 in handle
  File "/home/dje/cpython-buildarea/3.x.edelsohn-debian-z/build/Lib/unittest/case.py", line 782 in assertRaises
  File "/home/dje/cpython-buildarea/3.x.edelsohn-debian-z/build/Lib/test/test_slice.py", line 107 in test_cmp
  File "/home/dje/cpython-buildarea/3.x.edelsohn-debian-z/build/Lib/unittest/case.py", line 642 in run
  File "/home/dje/cpython-buildarea/3.x.edelsohn-debian-z/build/Lib/unittest/case.py", line 702 in __call__
  ...
msg335321 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-02-12 16:28
When the test has been ran one more time in verbose mode, it passed.
msg335322 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-02-12 16:31
I'm unable to reproduce the issue on my Fedora 29 (x86-64) laptop. I used two terminals:

* ./python -m test -F -j0 test_slice test_slice test_slice test_slice test_slice test_slice test_slice test_slice
* ./python -m test -j0 -u all,-gui -r # stress the system to randomize timings in test_slice
msg335323 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-02-12 16:34
Duplicate of issue35961 ? It occurs in Travis too
msg335324 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-02-12 16:36
Sorry, it occurs in Travis too randomly not consistently.
History
Date User Action Args
2019-02-12 16:47:07vstinnersetstatus: open -> closed
superseder: test_slice: gc_decref: Assertion "gc_get_refs(g) > 0" failed: refcount is too small
resolution: duplicate
stage: resolved
2019-02-12 16:36:49xtreaksetmessages: + msg335324
2019-02-12 16:34:12xtreaksetnosy: + xtreak
messages: + msg335323
2019-02-12 16:31:10vstinnersetmessages: + msg335322
2019-02-12 16:28:09vstinnersetmessages: + msg335321
2019-02-12 16:27:40vstinnercreate