classification
Title: Intermitent failure in test_multiprocessing.test_number_of_objects
Type: behavior Stage: resolved
Components: Library (Lib), Tests Versions: Python 3.0
process
Status: closed Resolution: duplicate
Dependencies: Superseder: multiprocessing: failure in manager._debug_info()
View: 5009
Assigned To: jnoller Nosy List: flox, jnoller, pitrou
Priority: high Keywords:

Created on 2008-08-15 21:08 by pitrou, last changed 2010-02-09 14:23 by flox. This issue is now closed.

Messages (2)
msg71184 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2008-08-15 21:08
Just got the following on trunk:

test test_multiprocessing failed -- Traceback (most recent call last):
  File "/home/antoine/py3k/memapi/Lib/test/test_multiprocessing.py",
line 1040, in test_number_of_objects
    print(self.manager._debug_info())
  File "/home/antoine/py3k/memapi/Lib/multiprocessing/managers.py", line
555, in _debug_info
    return dispatch(conn, None, 'debug_info')
  File "/home/antoine/py3k/memapi/Lib/multiprocessing/managers.py", line
85, in dispatch
    raise convert_to_error(kind, result)
multiprocessing.managers.RemoteError: 
---------------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/py3k/memapi/Lib/multiprocessing/managers.py", line
187, in handle_request
    result = func(c, *args, **kwds)
  File "/home/antoine/py3k/memapi/Lib/multiprocessing/managers.py", line
305, in debug_info
    keys.sort()
TypeError: unorderable types: str() < int()
---------------------------------------------------------------------------
msg99117 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-02-09 14:23
Duplicate of #5009. Applied in r68839.
History
Date User Action Args
2010-02-09 14:23:50floxsetstatus: open -> closed

superseder: multiprocessing: failure in manager._debug_info()

nosy: + flox
messages: + msg99117
resolution: duplicate
stage: resolved
2008-08-15 21:09:16pitrousetversions: + Python 3.0, - Python 2.6
2008-08-15 21:08:56pitroucreate