classification
Title: Docstring typos
Type: Stage:
Components: Documentation Versions: Python 3.0, Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: Rambo007, georg.brandl, gpolo
Priority: normal Keywords:

Created on 2008-08-10 22:16 by Rambo007, last changed 2008-08-11 08:18 by georg.brandl. This issue is now closed.

Messages (3)
msg70996 - (view) Author: (Rambo007) Date: 2008-08-10 22:16
Hello. I was pokinf around in the Python 3.0b2 interpreter and I found
some typos in the following doctring:

>>> import sys; print(sys.platform.__doc__)
str(string[, encoding[, errors]]) -> str

Create a new string object from the given encoded string.
encoding defaults to the current default string encoding.
errors can be 'strict', 'replace' or 'ignore' and defaults to 'strict'.



Please fix the docstring words 'encoding' and 'errors' to have the
capital initial letter, so that the docstring would look like this:
str(string[, encoding[, errors]]) -> str

Create a new string object from the given encoded string.
Encoding defaults to the current default string encoding.
Errors can be 'strict', 'replace' or 'ignore' and defaults to 'strict'.



Please fix other similar typos if you find them. Thank you.
msg70997 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2008-08-10 22:46
'encoding' and 'errors' refers to the names of the arguments accepted by
str, this is not a typo.
msg71002 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-08-11 08:18
Chester, please stop changing your user name and wasting our time.
History
Date User Action Args
2008-08-11 08:18:16georg.brandlsetmessages: + msg71002
2008-08-10 22:46:32gpolosetstatus: open -> closed
nosy: + gpolo
resolution: not a bug
messages: + msg70997
2008-08-10 22:16:33Rambo007create