classification
Title: Mac, 3.0 framework install error with fink cp
Type: compile error Stage:
Components: macOS Versions: Python 3.0, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, robind, ronaldoussoren
Priority: normal Keywords:

Created on 2008-07-24 02:43 by robind, last changed 2010-04-29 17:46 by terry.reedy. This issue is now closed.

Messages (5)
msg70190 - (view) Author: Robin Dunn (robind) Date: 2008-07-24 02:43
OSX Leopard (10.5.4)
Python-3.0b2 tarball 

./configure --enable-universalsdk --enable-framework 
make
sudo make install 

Ends with this error:
cd PythonLauncher && make install DESTDIR=
test -d "/Applications/Python 3.0" || mkdir -p "/Applications/Python 3.0"
test -d "/Applications/Python 3.0/Python Launcher.app" && rm -r
"/Applications/Python 3.0/Python Launcher.app"
cp -r "Python Launcher.app" "/Applications/Python 3.0"
touch "/Applications/Python 3.0/Python Launcher.app"
test -d "/Applications/Python 3.0" || mkdir -p "/Applications/Python 3.0"
test -d "/Applications/Python 3.0/IDLE.app" && rm -r
"/Applications/Python 3.0/IDLE.app"
make[1]: [install_IDLE] Error 1 (ignored)
cp -PR IDLE/IDLE.app "/Applications/Python 3.0"
cp: Warning: the meaning of `-P' will change in the future to conform to
POSIX.
Use `--parents' for the old meaning, and `--no-dereference' for the new one.
ln -sf
/Library/Frameworks/Python.framework/Versions/3.0/Resources/Python.app/Contents/MacOS/Python
"/Applications/Python 3.0/IDLE.app/Contents/MacOS/Python"
ln: creating symbolic link `/Applications/Python
3.0/IDLE.app/Contents/MacOS/Python' to
`/Library/Frameworks/Python.framework/Versions/3.0/Resources/Python.app/Contents/MacOS/Python':
No such file or directory
make[1]: *** [install_IDLE] Error 1
make: *** [frameworkinstallapps] Error 2


It looks like this is due to fink's cp being found first on the PATH. 
Temporarily disabling /sw/bin/cp so /bin/cp would be found first then
the install finished.
msg70203 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-07-24 13:41
Isn't this a Fink problem then?
msg70205 - (view) Author: Robin Dunn (robind) Date: 2008-07-24 14:29
Maybe, but I think that a more proper approach would be one of the
following:

* Decide that features specific to Apple's cp are required and change
the Makefile to use /bin/cp instead of just cp.

* Use configure to determine if a GNU cp is present and if so adjust the
command-line parameters used.

* Just use the $(INSTALL) value already set by configure as already used
in the main Makefile.
msg74434 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2008-10-07 10:10
IMHO the best fix would be to use "/bin/cp" instead of plain "cp". It is 
not possible to use $(INSTALL) here because this step does a recursive 
copy.

NOTE: The same fix should also be applied to the trunk and release26-maint 
branch.
msg78785 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2009-01-02 11:49
Fixed in r68150 (python-trunk), r68151 (python 2.6.x), r68152 (python 
3.x).

Could someone that actually has Fink installed confirm that the issue is 
actually fixed? My patch consists of changing 'cp' to '/bin/cp' to ensure 
that the system copy of that command is used.
History
Date User Action Args
2010-04-29 17:46:13terry.reedysetstatus: pending -> closed
2009-01-02 11:49:58ronaldoussorensetstatus: open -> pending
resolution: fixed
messages: + msg78785
title: libtk -> Mac, 3.0 framework install error with fink cp
2009-01-01 03:19:15MLModelsettitle: Mac, 3.0 framework install error with fink cp -> libtk
2008-10-07 10:10:19ronaldoussorensetversions: + Python 2.6
2008-10-07 10:10:04ronaldoussorensetnosy: + ronaldoussoren
messages: + msg74434
2008-07-24 14:29:31robindsetmessages: + msg70205
2008-07-24 13:41:36benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg70203
2008-07-24 02:43:29robindcreate