classification
Title: Python latest release 2.7 shows SSL error
Type: compile error Stage: resolved
Components: SSL Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: christian.heimes Nosy List: Janibasha, Michael.Felt, christian.heimes
Priority: normal Keywords:

Created on 2018-07-20 05:45 by Janibasha, last changed 2018-07-20 23:22 by brett.cannon. This issue is now closed.

Files
File name Uploaded Description Edit
pip-error.JPG Janibasha, 2018-07-20 05:45 unable to install package using pip
Messages (3)
msg321981 - (view) Author: Janibasha (Janibasha) Date: 2018-07-20 05:45
I have downloaded & installed python latest 2.7 version (on date - 16th July). Initially i was unable to install even pip using cmd - python get-pip.py, somehow i managed to installed pip. Then i was unable to install any package using pip. It throws SSL error. Tried multiple ways to install but no go. No proxy or admin issues observed (admin confirmed the same). 

Then i uninstalled & reinstalled 2.7.10 which resolved the issue. 
Please check the attached screenshots and resolve it.
msg321982 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2018-07-20 05:53
This looks like a pip problem. Please open a bug report at https://github.com/pypa/pip
msg322000 - (view) Author: Michael Felt (Michael.Felt) * Date: 2018-07-20 11:01
There is a big chance it is not a direct issue with either python or pip / rather an issue with how current your "openssl" setup is.

As an example, using git I was not able to "pull" from a remote. This git (that also depends on python) has been working for ages. I "fixed" it by getting an updated "global" cacert.pem "chain of trust" installed and now https://... queries were working instantly.

So, did you perhaps, also update your SSL while re-installing/updating python2? (And also note, v2.7.10 is several years old. The latest v2.7 version is 2.7.15).
History
Date User Action Args
2018-07-20 23:22:58brett.cannonsetstatus: open -> closed
resolution: not a bug
stage: resolved
2018-07-20 11:01:47Michael.Feltsetnosy: + Michael.Felt
messages: + msg322000
2018-07-20 05:53:09christian.heimessetmessages: + msg321982
2018-07-20 05:45:22Janibashacreate