classification
Title: test_multiprocessing_spawn is leaking memory
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_multiprocessing_spawn leaked [1, 2, 1] memory blocks on AMD64 Windows8.1 Refleaks 3.7
View: 33735
Assigned To: Nosy List: pablogsal, vstinner
Priority: normal Keywords: buildbot

Created on 2018-06-13 15:10 by pablogsal, last changed 2018-06-13 19:40 by serhiy.storchaka. This issue is now closed.

Messages (2)
msg319471 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2018-06-13 15:10
The test `test_multiprocessing_spawn` is leaking memory according to the x86 Gentoo Refleaks 3.x buildbot:


x86 Gentoo Refleaks 3.x
http://buildbot.python.org/all/#/builders/1/builds/253

test_multiprocessing_spawn leaked [1, 2, 1] memory blocks, sum=4
1 test failed again:
    test_multiprocessing_spawn


x86 Gentoo Refleaks 3.7
http://buildbot.python.org/all/#/builders/114/builds/135
msg319472 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-06-13 15:30
Duplicate of bpo-33735.
History
Date User Action Args
2018-06-13 19:40:16serhiy.storchakasetstatus: open -> closed
stage: resolved
2018-06-13 15:30:29vstinnersetnosy: + vstinner
messages: + msg319472
resolution: duplicate

superseder: test_multiprocessing_spawn leaked [1, 2, 1] memory blocks on AMD64 Windows8.1 Refleaks 3.7
2018-06-13 15:10:40pablogsalcreate