classification
Title: lock not released in threading.Condition
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: lev.maximov, pitrou, tim.peters
Priority: normal Keywords:

Created on 2018-06-12 05:47 by lev.maximov, last changed 2018-06-15 19:00 by pitrou. This issue is now closed.

Messages (2)
msg319365 - (view) Author: Lev Maximov (lev.maximov) * Date: 2018-06-12 05:47
In `Condition.wait()` the `waiter` lock gets acquired twice, but is released only once (both in timeout and no timeout cases). Is it intentional?
msg319647 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2018-06-15 19:00
The `waiter` lock is always removed from `self._waiters` at the end of wait() (either by notify() or by wait() itself), so there's no point in releasing it a second time before destruction.

I'm closing this as it's not a bug.
History
Date User Action Args
2018-06-15 19:00:13pitrousetstatus: open -> closed

nosy: + pitrou, tim.peters
messages: + msg319647

resolution: not a bug
stage: resolved
2018-06-12 05:47:47lev.maximovcreate