classification
Title: Update overdue 'Deprecated ... removed in 3.x' messages
Type: Stage: resolved
Components: Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: remove deprecated HTMLParser.unescape
View: 37328
Assigned To: Nosy List: ezio.melotti, iritkatriel, serhiy.storchaka, terry.reedy, xtreak
Priority: normal Keywords:

Created on 2018-06-09 16:46 by terry.reedy, last changed 2020-09-17 23:46 by terry.reedy. This issue is now closed.

Messages (4)
msg319156 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-06-09 16:46
Reported on python-list by Vincent Vande Vivre.
"""
In Python-3.7.0b5 we can find at the end of html/parser.py:
    def unescape(self, s):
        warnings.warn('The unescape method is deprecated and will be removed '
                      'in 3.5, use html.unescape() instead.',
                      DeprecationWarning, stacklevel=2)
        return unescape(s)
"""
At minimum, /3.5/3.8 or after/  Since we often do not remove when we say we will, perhaps 'or after' should be routine.
msg325859 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2018-09-20 11:43
See also issue27032.
msg377070 - (view) Author: Irit Katriel (iritkatriel) * (Python committer) Date: 2020-09-17 22:48
This looks like a duplicate of issue27032 so I think it can be closed now.
msg377076 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2020-09-17 23:46
This is definitely moot as the method was removed in #37328 (rather than in #27032).  Thanks for catching this.
History
Date User Action Args
2020-09-17 23:46:00terry.reedysetstatus: open -> closed
resolution: duplicate
messages: + msg377076

superseder: remove deprecated HTMLParser.unescape
stage: resolved
2020-09-17 22:48:35iritkatrielsetnosy: + iritkatriel
messages: + msg377070
2018-09-20 11:43:09serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg325859
2018-09-20 11:31:16xtreaksetnosy: + xtreak
2018-06-09 16:46:24terry.reedycreate