classification
Title: Python.framework build is missing 'Current' symlink
Type: Stage: resolved
Components: macOS Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Missing symlink:Current after Mac OS X 3.3.2 package installation
View: 18117
Assigned To: Nosy List: hhas, ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2018-06-07 12:18 by hhas, last changed 2018-06-08 04:05 by ned.deily. This issue is now closed.

Messages (2)
msg318926 - (view) Author: (hhas) Date: 2018-06-07 12:18
The Python.framework installed at '/Library/Frameworks/Python.framework' should have a subdirectory structure similar to this:

    Python.framework
    |
    |-Headers [symlink to 'Versions/Current/Headers']
    |
    |-Python [symlink to 'Versions/Current/Python']
    |
    |-Resources [symlink to 'Versions/Current/Resources']
    |
    |-Versions
    | |
    | |-2.7 [directory created by 2.7 installer]
    | |
    | |-3.5 [directory created by 3.5 installer]
    | |
    | |-3.6 [directory created by 3.6 installer]
    | |
    | ...
    | |
    | |- Current [symlink to last installed version, e.g. '3.6']

Current Python.framework installers create a 2.x/3.x directory and Headers+Python+Resources symlinks, but fail to create a 'Current' symlink. This breaks the top-level symlinks and causes importing the framework via NSBundle to fail.

Please fix the framework build and/or install script to create the missing symlink.
msg319016 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-06-08 04:05
This is by design for Python 3 installs; Current *is* created for Python 2 installs for historical reasons.  See the discussion in Issue18117 why trying to use -framework Python is not a good idea unfortunately.
History
Date User Action Args
2018-06-08 04:05:57ned.deilysetstatus: open -> closed
superseder: Missing symlink:Current after Mac OS X 3.3.2 package installation
messages: + msg319016

resolution: duplicate
stage: resolved
2018-06-07 12:18:36hhascreate