classification
Title: python 3.7 and python 3.8 stable release
Type: behavior Stage: resolved
Components: Build Versions: Python 3.8, Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, sabakauser
Priority: normal Keywords:

Created on 2018-05-31 04:28 by sabakauser, last changed 2018-05-31 04:43 by ned.deily. This issue is now closed.

Messages (2)
msg318242 - (view) Author: Saba Kauser (sabakauser) Date: 2018-05-31 04:28
Hi,
I am planning to make new release of python ibm_db driver and I wanted to know the stable versions of python beyond python 3.6.

I can see python 3.8 marked as "in development" and I do read that python 3.7.0b4 is the final planned beta release preview. Would this mean that I cannot consider python 3.7 and python 3.8 for my next release and I would build only when these are marked stable.

Thank you!
Saba.
msg318249 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2018-05-31 04:43
We have just updated the release schedule for Python 3.7 to include 3.7.0b5, now available.  The 3.7.0 release candidate is now planned for 2018-06-11 with 3.7.0 final to follow on 2018-06-27.  We expect 3.7.0 to be adopted quickly but 3.6.x will be still supported for some time in the major distributions.  Python 3.8 is now in the early stages of development, with a final release currently planned for 2019-10 although that may change.  Information about current Python release plans are contained in and kept up-to-date in their respective PEPs:

3.6 https://www.python.org/dev/peps/pep-0494/
3.7 https://www.python.org/dev/peps/pep-0537/
3.8 https://www.python.org/dev/peps/pep-0569/

If you have further questions, please ask them on the Python-Dev mailing list:
https://mail.python.org/mailman/listinfo/python-dev
History
Date User Action Args
2018-05-31 04:43:55ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg318249

resolution: not a bug
stage: resolved
2018-05-31 04:28:43sabakausercreate