classification
Title: Buildbot configuration issue on Windows7 buildbots
Type: Stage: resolved
Components: Tests Versions: Python 3.8, Python 3.7, Python 3.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, vstinner, zach.ware
Priority: normal Keywords:

Created on 2018-05-24 11:31 by vstinner, last changed 2018-05-24 20:17 by zach.ware. This issue is now closed.

Messages (4)
msg317558 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-05-24 11:31
http://buildbot.python.org/all/#/builders/90/builds/342

D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build>"D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\PCbuild\win32\python_d.exe"  -u -Wd -E -bb -m test  -uall -rwW --slowest --timeout 1200 -j1 -j2 -uall -cpu -largefile --timeout 900 
usage: python -m test [options] [test_name1 [test_name2 ...]]
python path/to/Lib/test/regrtest.py [options] [test_name1 [test_name2 ...]]
regrtest.py: error: argument -l/--findleaks: ignored explicit argument 'argefile'
Pass -h or --help for complete help.
msg317560 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-05-24 11:44
Ned comment:

This is a side effect of our attempt to fix the test failures on this (Windows7) buildbot caused by "largefile" tests (see https://bugs.python.org/issue33355 ).  It should go away once the buildbot config gets manually updated.

https://github.com/python/buildmaster-config/pull/34
https://github.com/python/buildmaster-config/pull/35
msg317571 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-05-24 14:07
The configuration change is to fix bpo-33355.
msg317613 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2018-05-24 20:17
This was fixed by https://github.com/python/buildmaster-config/pull/36
History
Date User Action Args
2018-05-24 20:17:23zach.waresetstatus: open -> closed
resolution: fixed
messages: + msg317613

stage: resolved
2018-05-24 14:07:37vstinnersetmessages: + msg317571
2018-05-24 11:44:58vstinnersetmessages: + msg317560
2018-05-24 11:31:44vstinnercreate