classification
Title: test_sendfile_fallback_close_peer_in_middle_of_receiving() fails on x86-64 Sierra 3.x
Type: Stage: resolved
Components: asyncio, Tests Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_asyncio: test_sock_sendfile_mix_with_regular_send() hangs on FreeBSD
View: 33353
Assigned To: Nosy List: asvetlov, vstinner, yselivanov
Priority: normal Keywords:

Created on 2018-05-23 23:23 by vstinner, last changed 2018-05-24 00:32 by vstinner. This issue is now closed.

Messages (3)
msg317472 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-05-23 23:23
http://buildbot.python.org/all/#/builders/14/builds/1023

======================================================================
FAIL: test_sendfile_fallback_close_peer_in_middle_of_receiving (test.test_asyncio.test_events.KqueueEventLoopTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/buildbot/buildarea/3.x.billenstein-sierra/build/Lib/test/test_asyncio/test_events.py", line 2474, in test_sendfile_fallback_close_peer_in_middle_of_receiving
    self.loop.sendfile(cli_proto.transport, self.file))
AssertionError: ConnectionError not raised

======================================================================
FAIL: test_sendfile_fallback_close_peer_in_middle_of_receiving (test.test_asyncio.test_events.PollEventLoopTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/buildbot/buildarea/3.x.billenstein-sierra/build/Lib/test/test_asyncio/test_events.py", line 2474, in test_sendfile_fallback_close_peer_in_middle_of_receiving
    self.loop.sendfile(cli_proto.transport, self.file))
AssertionError: ConnectionError not raised

======================================================================
FAIL: test_sendfile_fallback_close_peer_in_middle_of_receiving (test.test_asyncio.test_events.SelectEventLoopTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/buildbot/buildarea/3.x.billenstein-sierra/build/Lib/test/test_asyncio/test_events.py", line 2474, in test_sendfile_fallback_close_peer_in_middle_of_receiving
    self.loop.sendfile(cli_proto.transport, self.file))
AssertionError: ConnectionError not raised
msg317478 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-05-23 23:35
The regression seems to be caused by my test_asyncio change for bpo-33353:
commit 2932755cc11fd82b4908d60b24b837aa4f3028e6
msg317482 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-05-24 00:32
I close this issue to move again the discussion to bpo-33353.
History
Date User Action Args
2018-05-24 00:32:27vstinnersetstatus: open -> closed
superseder: test_asyncio: test_sock_sendfile_mix_with_regular_send() hangs on FreeBSD
messages: + msg317482

resolution: duplicate
stage: resolved
2018-05-23 23:35:49vstinnersetmessages: + msg317478
2018-05-23 23:23:53vstinnercreate