classification
Title: Python 3.7: profile-opt build errors because a test seems to hang
Type: Stage: resolved
Components: Build Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Test hang causes --enable-optimizations build to hang
View: 37544
Assigned To: Nosy List: Rahul Ravindran, ned.deily
Priority: normal Keywords:

Created on 2018-05-11 18:22 by Rahul Ravindran, last changed 2019-07-21 14:44 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
stack_trace1.txt Rahul Ravindran, 2018-05-11 18:22
Messages (2)
msg316408 - (view) Author: Rahul Ravindran (Rahul Ravindran) Date: 2018-05-11 18:22
make run_profile_task

runs the tests and does not seem to have any mechanism to exclude tests that I could find based on looking at the Makefile.

Previously, on Python 3.6, this test test_poplib was failing(https://bugs.python.org/issue32753) and the profile_task would ignore failing tests. 

Now, with the Python 3.7 build, the test seems to hang and hence profile opt builds cannot be built.
Attached is the trace of the build based on Python-3.7.0b4
msg348247 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2019-07-21 14:44
Thanks for your report.  I'm sorry we haven't replied to it before now.  Similar behavior has been more recently reported in Issue37544 and there is discussion going on there.  So I am going to close your issue as a duplicate of it; feel free to join in the discussion there.
History
Date User Action Args
2019-07-21 14:44:18ned.deilysetstatus: open -> closed

superseder: Test hang causes --enable-optimizations build to hang

nosy: + ned.deily
messages: + msg348247
resolution: duplicate
stage: resolved
2018-05-11 18:22:19Rahul Ravindrancreate