classification
Title: python3 fails to build if directory or sysroot contains "*icc*" string
Type: compile error Stage: resolved
Components: Build Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: ICC compiler check is too permissive
View: 28584
Assigned To: Nosy List: locutusofborg, martin.panter, terry.reedy, vstinner
Priority: normal Keywords: patch

Created on 2018-04-23 10:12 by locutusofborg, last changed 2018-05-19 00:38 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
icc-find.patch locutusofborg, 2018-05-17 15:13
Messages (6)
msg315656 - (view) Author: Gianfranco (locutusofborg) * Date: 2018-04-23 10:12
Hello, as said, in yocto we pass in $CC environment, also the --sysroot keyword.

If --sysroot contains the "*icc*" or "*gcc*" in path, the build fails because of wrong autoconf checks.

checking in a case switch for *icc* seems bad to me, I propose to change it with something like
"*icc" so we might exclude when icc is not the compiler.

I know this isn't a strong patch, but maybe we can apply it while writing some better detect code.

The build fails as descripted in the yocto bug
https://bugzilla.yoctoproject.org/show_bug.cgi?id=12703
msg315805 - (view) Author: Gianfranco (locutusofborg) * Date: 2018-04-26 16:33
I signed the contributor agreement, even if such patches shouldn't need any kind of license
msg315854 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-04-27 18:52
Thank you. Yes, we require a signed CA for something this non-trivial.

Victor, I don't know who maintains configure.  If you don't, maybe you know who does.
msg316920 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2018-05-17 12:32
Maybe this is the same as Issue 28584, about the ${CC} variable rather than “sysroot”. In any case, the patch looks unrelated.
msg316945 - (view) Author: Gianfranco (locutusofborg) * Date: 2018-05-17 15:13
This was the patch I wanted to add, but I picked up a wrong one (a vbox one)

In any case, duplicate of issue28584
msg316948 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-05-17 15:35
icc-find.patch (and a 2nd version) has been uploaded to #28584 also. I unlinked the erroneous upload 'patch'.
History
Date User Action Args
2018-05-19 00:38:18vstinnersetnosy: + vstinner
2018-05-19 00:37:26vstinnersetnosy: - vstinner
2018-05-17 15:35:11terry.reedysetmessages: + msg316948
2018-05-17 15:34:20terry.reedysetfiles: - patch
2018-05-17 15:31:11terry.reedysetstatus: open -> closed
superseder: ICC compiler check is too permissive
stage: patch review -> resolved
2018-05-17 15:13:40locutusofborgsetfiles: + icc-find.patch
resolution: duplicate
messages: + msg316945

keywords: + patch
2018-05-17 12:32:34martin.pantersetnosy: + martin.panter
messages: + msg316920
2018-04-27 18:52:07terry.reedysetnosy: + vstinner, terry.reedy

messages: + msg315854
stage: patch review
2018-04-26 16:33:49locutusofborgsetmessages: + msg315805
2018-04-23 10:12:22locutusofborgcreate