classification
Title: TimedRotatingFileHandler in logging module
Type: enhancement Stage: resolved
Components: Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Nikunj jain, nitishch, vinay.sajip
Priority: normal Keywords:

Created on 2018-03-28 08:02 by Nikunj jain, last changed 2018-04-03 03:33 by vinay.sajip. This issue is now closed.

Messages (2)
msg314569 - (view) Author: Nikunj jain (Nikunj jain) Date: 2018-03-28 08:02
Currently the TimedRotatingFileHandler in Python, when rotates the log file, invents a new file extension by adding the new date in the end of the file name. It would be really good if a prefix option could be provided which instead of adding the new date in end, will add it in the beginning.
msg314856 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2018-04-03 03:33
You can already roll your own, see

https://docs.python.org/3/library/logging.handlers.html#baserotatinghandler
History
Date User Action Args
2018-04-03 03:33:52vinay.sajipsetstatus: open -> closed
resolution: not a bug
messages: + msg314856

stage: resolved
2018-04-02 19:50:02ned.deilysetnosy: + vinay.sajip
2018-04-02 05:54:16nitishchsetnosy: + nitishch
2018-03-28 08:02:50Nikunj jaincreate