classification
Title: pdb from base class, get inside a method of derived class
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ishanSrt, terry.reedy
Priority: normal Keywords:

Created on 2018-03-10 21:41 by ishanSrt, last changed 2018-03-16 21:32 by terry.reedy. This issue is now closed.

Messages (2)
msg313557 - (view) Author: Ishan Srivastava (ishanSrt) Date: 2018-03-10 21:41
I need to use `pdb.set_trace()` in the base class. It has a method:

```
def run(self, *args, **kwargs):
    raise NotImplementedError
```
Since this base class is derived by many subclasses I don't know before hand which class' `run()` method I need to get inside. Also there is some pre processing of the arguments given to the `run()` method. So when `pdb` reaches the line,

```
q=self.run(arguments)
```

and I hit `s` it acts as if I have given the command `next`.

How can I get inside the derived class' `run()` method with `pdb` and debug the code over there?
msg313974 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2018-03-16 21:32
bugs.python.org is for issues about patching the Python docs or the CPython implementation, for future releases.  Questions about using python/cpython should go to Q&A forums, such a python-list or Stackoverflow.
History
Date User Action Args
2018-03-16 21:32:49terry.reedysetstatus: open -> closed

nosy: + terry.reedy
messages: + msg313974

resolution: not a bug
stage: resolved
2018-03-10 21:41:25ishanSrtcreate