classification
Title: Doc: The new dataclasses module is not documented
Type: Stage: resolved
Components: Documentation Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, eric.smith, vstinner
Priority: normal Keywords:

Created on 2017-12-21 23:37 by vstinner, last changed 2017-12-21 23:45 by eric.smith. This issue is now closed.

Messages (2)
msg308918 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-12-21 23:37
bpo-32214 "Implement PEP 557: Data Classes" added a new dataclasses module and was closed, but the new module is not documented:
https://docs.python.org/dev/library/dataclasses.html

And it's also missing from What's New in Python 3.7:
https://docs.python.org/dev/whatsnew/3.7.html
msg308919 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2017-12-21 23:45
This is a duplicate of #32216, which is no doubt hard to find because the subject doesn't contain "dataclasses". I've fixed that.
History
Date User Action Args
2017-12-21 23:45:25eric.smithsetstatus: open -> closed
resolution: duplicate
messages: + msg308919

stage: resolved
2017-12-21 23:37:58vstinnercreate