classification
Title: cgi: TypeError when no argument string is found
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: cgi.FieldStorage can't parse simple body with Content-Length and no Content-Disposition
View: 27777
Assigned To: Nosy List: berker.peksag, srittau
Priority: normal Keywords:

Created on 2017-11-15 00:31 by srittau, last changed 2017-11-15 01:53 by berker.peksag. This issue is now closed.

Messages (2)
msg306244 - (view) Author: Sebastian Rittau (srittau) * Date: 2017-11-15 00:31
Consider the following code:

    import cgi
    from io import BytesIO

    cgi.FieldStorage(BytesIO(b"{}"), environ={
        "REQUEST_METHOD": "POST",
        "CONTENT_TYPE": "application/json",
        "CONTENT_LENGTH": "14",
    })

This will throw the following exception:

Traceback (most recent call last):
  File "foo.py", line 7, in <module>
    "CONTENT_LENGTH": "14",
  File "/usr/lib/python3.6/cgi.py", line 561, in __init__
    self.read_single()
  File "/usr/lib/python3.6/cgi.py", line 740, in read_single
    self.read_binary()
  File "/usr/lib/python3.6/cgi.py", line 762, in read_binary
    self.file.write(data)
TypeError: write() argument must be str, not bytes

Of course, the input does not contain any argument string to be parsed by FieldStorage. Nevertheless, a TypeError in a totally unrelated part of the code seems like a bug. In my opinion, FieldStorage should just remain empty in this case, or - at best - throw a ValueError with a sensible error message.
msg306248 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2017-11-15 01:53
Thank you for your report. This looks like a duplicate of issue 27777. You might workaround this by passing ``headers={"Content-Disposition": "inline"}`` to cgi.FieldStorage() (untested)
History
Date User Action Args
2017-11-15 01:53:55berker.peksagsetstatus: open -> closed

superseder: cgi.FieldStorage can't parse simple body with Content-Length and no Content-Disposition
type: behavior

nosy: + berker.peksag
messages: + msg306248
resolution: duplicate
stage: resolved
2017-11-15 00:33:30srittausetcomponents: + Library (Lib)
title: cgi: TypeError -> cgi: TypeError when no argument string is found
2017-11-15 00:31:53srittaucreate