classification
Title: test_emails failure on FreeBSD
Type: behavior Stage: resolved
Components: email, Tests Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_email: test_localtime_daylight_false_dst_true() fails depending on the timezone
View: 35317
Assigned To: Nosy List: barry, belopolsky, lemburg, r.david.murray, serhiy.storchaka, skrah, vstinner, xtreak
Priority: normal Keywords:

Created on 2017-09-29 07:20 by serhiy.storchaka, last changed 2018-11-26 15:47 by vstinner. This issue is now closed.

Messages (3)
msg303305 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-09-29 07:20
$ ./python -m test -vuall test_email
...
======================================================================
ERROR: test_localtime_daylight_false_dst_true (test.test_email.test_utils.LocaltimeTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/serhiy/py/cpython3.7-debug/Lib/test/test_email/test_utils.py", line 88, in test_localtime_daylight_false_dst_true
    t1 = utils.localtime(t0, isdst=1)
  File "/usr/home/serhiy/py/cpython3.7-debug/Lib/email/utils.py", line 373, in localtime
    seconds = time.mktime(tm)
OverflowError: mktime argument out of range

======================================================================
ERROR: test_localtime_daylight_true_dst_true (test.test_email.test_utils.LocaltimeTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/serhiy/py/cpython3.7-debug/Lib/test/test_email/test_utils.py", line 81, in test_localtime_daylight_true_dst_true
    t1 = utils.localtime(t0, isdst=1)
  File "/usr/home/serhiy/py/cpython3.7-debug/Lib/email/utils.py", line 373, in localtime
    seconds = time.mktime(tm)
OverflowError: mktime argument out of range

----------------------------------------------------------------------
msg326335 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python triager) Date: 2018-09-25 08:56
I just searched for the error and a very similar or in fact the same issue that fails with the same test was reported. It was closed as outdated since there were no errors on buildbots I hope. Adding it here the issue here that might be helpful in debugging. 

I would propose closing this and reopening the other issue which might be helpful since it has more context and Serhiy can still reproduce this on FreeBSD with 3.7. Thoughts on closing this?

Relevant issue : https://bugs.python.org/issue15750

Thanks
msg330440 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2018-11-26 15:47
I mark this issue as a duplicate of bpo-35317.
History
Date User Action Args
2018-11-26 15:47:04vstinnersetstatus: open -> closed

superseder: test_email: test_localtime_daylight_false_dst_true() fails depending on the timezone

nosy: + vstinner
messages: + msg330440
resolution: duplicate
stage: resolved
2018-09-25 08:56:17xtreaksetmessages: + msg326335
2018-09-20 12:38:12xtreaksetnosy: + xtreak
2018-05-05 17:16:40serhiy.storchakasetnosy: + lemburg, belopolsky
2017-09-29 07:20:14serhiy.storchakacreate