classification
Title: problem in math
Type: performance Stage: resolved
Components: Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: aneesh317, vstinner
Priority: normal Keywords:

Created on 2017-09-25 13:09 by aneesh317, last changed 2017-09-25 13:20 by aneesh317. This issue is now closed.

Messages (3)
msg302955 - (view) Author: ANEESH JOSE (aneesh317) Date: 2017-09-25 13:09
We know that the answer of sin 90 is 1.
But In Python's library math,the value of it is around 0.83...
My program is as follows:
import math
a=math.sin(90)
print(a)
#Output obtained is 0.83.....
Hope you guys solve this on the next update or nearby
I hope it is a small issue.But the credibility of program depends upon every minute particles
msg302956 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-09-25 13:10
It seems like you are confused between radians and degrees. math.sin() expects radians.
https://docs.python.org/dev/library/math.html#math.sin

Sorry but the Python bug tracker is not the right to ask questions. I close your bug report.
msg302957 - (view) Author: ANEESH JOSE (aneesh317) Date: 2017-09-25 13:20
Thankyou for the information .
History
Date User Action Args
2017-09-25 13:20:01aneesh317setnosy: vstinner, aneesh317
messages: + msg302957
2017-09-25 13:10:52vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg302956

resolution: not a bug
stage: resolved
2017-09-25 13:09:14aneesh317create