classification
Title: segfault in PyBytes_AsString
Type: crash Stage: resolved
Components: Interpreter Core Versions: Python 3.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: BTaskaya, Tim Smith, vstinner, xtreak
Priority: normal Keywords:

Created on 2017-09-19 18:19 by Tim Smith, last changed 2020-03-26 00:38 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
python-segfault.txt Tim Smith, 2017-09-19 18:19 coredumpctl -1 info
Messages (4)
msg302553 - (view) Author: Tim Smith (Tim Smith) Date: 2017-09-19 18:19
$ python -V
Python 3.6.2

This crash appears to be specific to having files with some ill-encoded filenames. After renaming the offending files to remove the non-ASCII characters, the process could complete without crashing.

$ beet import /share/Music/Berliner\ Philharmoniker\;\ Herbert\ von\ Karajan
/share/Music/Berliner Philharmoniker; Herbert von Karajan/Tristan und Isolde; Tannhuser; Die Meistersinger von Nrnberg (5 items)
Correcting tags from:                                                                                                                                          
    Berliner Philharmoniker; Herbert von Karajan - Tristan und Isolde; Tannhäuser; Die Meistersinger von Nürnberg                                              
To:                                                                                                                                                            
    Richard Wagner; Berliner Philharmoniker; Herbert von Karajan - Tristan und Isolde / Tannhäuser / Die Meistersinger von Nürnberg                            
URL:                                                                                                                                           
    https://musicbrainz.org/release/7d2cbceb-7981-4eb4-a264-0dae5b6cba55                 
(Similarity: 92.9%) (artist, year, tracks) (CD, 1994, DE, Deutsche Grammophon)                                                                                 
 * Tannhäuser und der Sängerkrieg auf Wartburg - Ouvertüre              -> Tannhäuser und der Sängerkrieg auf Wartburg: Overtüre (title)
 * Tannhäuser und der Sängerkrieg auf Wartburg - Bacchanale (Venusberg) -> Tannhäuser und der Sängerkrieg auf Wartburg: Bacchanale (Venusberg)
 * Die Meistersinger von Nürnberg - Vorspiel zum 3. Aufzug              -> Die Meistersinger von Nürnberg: Vorspiel zum 3. Aufzug
 * Tristan und Isolde - Vorspiel                                        -> Tristan und Isolde: Vorspiel                                                        
 * Tristan und Isolde - Isoldes Liebestod                               -> Tristan und Isolde: Isoldes Liebstod (title)                                        
[A]pply, More candidates, Skip, Use as-is, as Tracks, Group albums,                                                                                            
Enter search, enter Id, aBort, Print tracks, eDit, edit Candidates?                                                                                            
[1]    22921 segmentation fault (core dumped)  beet import /share/Music/Berliner\ Philharmoniker\;\ Herbert\ von\ Karajan


Please find full output of `coredumpctl info` in the attached file.

                Stack trace of thread 22932:
                #0  0x00007fd216e23514 PyBytes_AsString (libpython3.6m.so.1.0)
                #1  0x00007fd206dfc904 n/a (_gi.cpython-36m-x86_64-linux-gnu.so)
                #2  0x00007fd206dfd196 n/a (_gi.cpython-36m-x86_64-linux-gnu.so)
                #3  0x00007fd206dfc25f n/a (_gi.cpython-36m-x86_64-linux-gnu.so)
                #4  0x00007fd206ddfddf n/a (_gi.cpython-36m-x86_64-linux-gnu.so)
                #5  0x00007fd206de01fb n/a (_gi.cpython-36m-x86_64-linux-gnu.so)
                #6  0x00007fd216e4d974 _PyCFunction_FastCallDict (libpython3.6m.so.1.0)
                #7  0x00007fd216e4b82a n/a (libpython3.6m.so.1.0)
                #8  0x00007fd216de92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #9  0x00007fd216e4b34a n/a (libpython3.6m.so.1.0)
                #10 0x00007fd216e4b8ee n/a (libpython3.6m.so.1.0)
                #11 0x00007fd216de92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #12 0x00007fd216e4b34a n/a (libpython3.6m.so.1.0)
                #13 0x00007fd216e4b8ee n/a (libpython3.6m.so.1.0)
                #14 0x00007fd216de92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #15 0x00007fd216e4b34a n/a (libpython3.6m.so.1.0)
                #16 0x00007fd216e4b8ee n/a (libpython3.6m.so.1.0)
                #17 0x00007fd216de92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #18 0x00007fd216e4a48d n/a (libpython3.6m.so.1.0)
                #19 0x00007fd216e4b571 n/a (libpython3.6m.so.1.0)
                #20 0x00007fd216e4b8ee n/a (libpython3.6m.so.1.0)
                #21 0x00007fd216de92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #22 0x00007fd216e4adba _PyFunction_FastCallDict (libpython3.6m.so.1.0)
                #23 0x00007fd216e0edce _PyObject_FastCallDict (libpython3.6m.so.1.0)
                #24 0x00007fd216e0f9d1 _PyObject_Call_Prepend (libpython3.6m.so.1.0)
                #25 0x00007fd216e0fabb PyObject_Call (libpython3.6m.so.1.0)
                #26 0x00007fd216dea891 _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #27 0x00007fd216e4a48d n/a (libpython3.6m.so.1.0)
                #28 0x00007fd216e4b571 n/a (libpython3.6m.so.1.0)
                #29 0x00007fd216e4b8ee n/a (libpython3.6m.so.1.0)
                #30 0x00007fd216de92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #31 0x00007fd216e4bda7 PyEval_EvalCodeEx (libpython3.6m.so.1.0)
                #32 0x00007fd216e82cd3 n/a (libpython3.6m.so.1.0)
                #33 0x00007fd216e0fabb PyObject_Call (libpython3.6m.so.1.0)
                #34 0x00007fd216dea891 _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #35 0x00007fd216e88334 _PyGen_Send (libpython3.6m.so.1.0)
                #36 0x00007fd216e4d9e5 _PyCFunction_FastCallDict (libpython3.6m.so.1.0)
                #37 0x00007fd216e4b82a n/a (libpython3.6m.so.1.0)
                #38 0x00007fd216de92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #39 0x00007fd216e4b34a n/a (libpython3.6m.so.1.0)
                #40 0x00007fd216e4b8ee n/a (libpython3.6m.so.1.0)
                #41 0x00007fd216de92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #42 0x00007fd216e4b34a n/a (libpython3.6m.so.1.0)
                #43 0x00007fd216e4b8ee n/a (libpython3.6m.so.1.0)
                #44 0x00007fd216de92ea _PyEval_EvalFrameDefault (libpython3.6m.so.1.0)
                #45 0x00007fd216e4adba _PyFunction_FastCallDict (libpython3.6m.so.1.0)
                #46 0x00007fd216e0edce _PyObject_FastCallDict (libpython3.6m.so.1.0)
                #47 0x00007fd216e0f9d1 _PyObject_Call_Prepend (libpython3.6m.so.1.0)
                #48 0x00007fd216e0fabb PyObject_Call (libpython3.6m.so.1.0)
                #49 0x00007fd216eb1862 n/a (libpython3.6m.so.1.0)
                #50 0x00007fd2175ee08a start_thread (libpthread.so.0)
                #51 0x00007fd2173261bf __clone (libc.so.6)

The file names:

$ find Berliner\ Philharmoniker\;\ Herbert\ von\ Karajan -ls
      392     16 drwxrwxr-x   3  tsmith   users       16384 Jun 19  2016 Berliner\ Philharmoniker;\ Herbert\ von\ Karajan
      575     16 drwxrwxr-x   2  tsmith   users       16384 Jun 19  2016 Berliner\ Philharmoniker;\ Herbert\ von\ Karajan/Tristan\ und\ Isolde;\ Tannh\344user;\ Die\ Meistersinger\ von\ N\374rnberg
      581  15344 -rwxrwxr-x   1  tsmith   users    15697348 Feb 13  2014 Berliner\ Philharmoniker;\ Herbert\ von\ Karajan/Tristan\ und\ Isolde;\ Tannh\344user;\ Die\ Meistersinger\ von\ N\374rnberg/02\ Tannh\344user\ und\ der\ S\344ngerkrieg\ auf\ Wartburg\ -\ Bacchanale\ (Venusberg).mp3
      582  12752 -rwxrwxr-x   1  tsmith   users    13043294 Feb 13  2014 Berliner\ Philharmoniker;\ Herbert\ von\ Karajan/Tristan\ und\ Isolde;\ Tannh\344user;\ Die\ Meistersinger\ von\ N\374rnberg/01\ Tannh\344user\ und\ der\ S\344ngerkrieg\ auf\ Wartburg\ -\ Ouvert\374re.mp3
      583   7760 -rwxrwxr-x   1  tsmith   users     7934265 Feb 13  2014 Berliner\ Philharmoniker;\ Herbert\ von\ Karajan/Tristan\ und\ Isolde;\ Tannh\344user;\ Die\ Meistersinger\ von\ N\374rnberg/03\ Die\ Meistersinger\ von\ N\374rnberg\ -\ Vorspiel\ zum\ 3.\ Aufzug.mp3
      584  14544 -rwxrwxr-x   1  tsmith   users    14879676 Feb 13  2014 Berliner\ Philharmoniker;\ Herbert\ von\ Karajan/Tristan\ und\ Isolde;\ Tannh\344user;\ Die\ Meistersinger\ von\ N\374rnberg/04\ Tristan\ und\ Isolde\ -\ Vorspiel.mp3
      585   8592 -rwxrwxr-x   1  tsmith   users     8784795 Feb 13  2014 Berliner\ Philharmoniker;\ Herbert\ von\ Karajan/Tristan\ und\ Isolde;\ Tannh\344user;\ Die\ Meistersinger\ von\ N\374rnberg/05\ Tristan\ und\ Isolde\ -\ Isoldes\ Liebestod.mp3


I renamed the files with commands like:

$ mv 03\ Die\ Meistersinger\ von\ N$'\374'rnberg\ -\ Vorspiel\ zum\ 3.\ Aufzug.mp3 03.mp3
msg302555 - (view) Author: Tim Smith (Tim Smith) Date: 2017-09-19 18:24
I forgot to mention, this is Arch Linux python package:

Version         : 3.6.2-1
Packager        : Felix Yan <felixonmars@archlinux.org>
Build Date      : Wed 19 Jul 2017 01:54:34 PM MDT

I had the files on a vfat filesystem, but copied them to ext4 with the exact same results.
msg356926 - (view) Author: Batuhan Taskaya (BTaskaya) * (Python committer) Date: 2019-11-18 22:44
Is there a simpler code for reproducing the issue?
msg365038 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-03-26 00:38
That's very likely a crash in third party project.

Since no reproducer was provided that the last message of the reporter was 3 years ago, I close the issue.
History
Date User Action Args
2020-03-26 00:38:21vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg365038

resolution: out of date
stage: resolved
2019-11-18 22:44:33BTaskayasetnosy: + BTaskaya
messages: + msg356926
2018-09-22 17:35:33xtreaksetnosy: + xtreak
2017-09-19 18:24:32Tim Smithsetmessages: + msg302555
2017-09-19 18:19:05Tim Smithcreate