classification
Title: test_subprocess hangs randomly on AMD64 Windows10 3.x
Type: Stage: resolved
Components: Versions: Python 3.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, vstinner
Priority: normal Keywords:

Created on 2017-09-18 16:16 by vstinner, last changed 2017-10-13 13:55 by vstinner. This issue is now closed.

Messages (4)
msg302467 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-09-18 16:16
http://buildbot.python.org/all/builders/AMD64%20Windows10%203.x/builds/1242/steps/test/logs/stdio

0:49:36 [401/405] test_osx_env passed
0:49:38 [402/405] test_fractions passed -- running: test_subprocess (31 sec)
0:49:51 [403/405] test_importlib passed -- running: test_subprocess (44 sec)
0:49:53 [404/405] test_pwd skipped -- running: test_subprocess (46 sec)
test_pwd skipped -- No module named 'pwd'

command timed out: 1200 seconds without output running ['Tools\\buildbot\\test.bat', '-x64', '-j2', '--timeout', '900'], attempting to kill
program finished with exit code 1
elapsedTime=4198.024000

See also bpo-30885.
msg302608 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-09-20 12:50
As expected, I'm unable to reproduce the bug on my Windows VM, even using --forever during 1 hour:
python -m test test_subprocess -v --timeout=120 --forever.
msg304306 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2017-10-13 05:09
I also have seen test_subprocess hangs on both macOS and on Debian Linux on both 3.6 and master, as recently as 3.6.3 and 3.7.0a1 but not with current heads.  After some experimenting and bisecting, I tracked the fix down to the mock os.waitpid fixes for bpo-31178 (git11045c9d8a and gitfae0512e58). So perhaps this issue can be closed.
msg304339 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-10-13 13:55
Ned: "I also have seen test_subprocess hangs on both macOS and on Debian Linux on both 3.6 and master, as recently as 3.6.3 and 3.7.0a1 but not with current heads.  After some experimenting and bisecting, I tracked the fix down to the mock os.waitpid fixes for bpo-31178 (git11045c9d8a and gitfae0512e58). So perhaps this issue can be closed."

Oh, that's a very good news. Thanks!
History
Date User Action Args
2017-10-13 13:55:14vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg304339

stage: resolved
2017-10-13 05:09:29ned.deilysetnosy: + ned.deily
messages: + msg304306
2017-09-20 12:50:31vstinnersetmessages: + msg302608
2017-09-18 16:16:13vstinnercreate