classification
Title: [3.6] Python/random.c:128:17: warning: implicit declaration of function 'getrandom'
Type: Stage: resolved
Components: Build Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: vstinner
Priority: normal Keywords:

Created on 2017-09-12 17:41 by vstinner, last changed 2017-09-12 17:51 by vstinner. This issue is now closed.

Messages (2)
msg301981 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-09-12 17:41
haypo@selma$ touch Python/random.c 
haypo@selma$ LANG= make

gcc -pthread -c -Wno-unused-result -Wsign-compare -g -Og -Wall -Wstrict-prototypes -O0   -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers   -I. -I./Include    -DPy_BUILD_CORE -o Python/random.o Python/random.c
Python/random.c: In function 'py_getrandom':
Python/random.c:128:17: warning: implicit declaration of function 'getrandom'; did you mean 'py_getrandom'? [-Wimplicit-function-declaration]
             n = getrandom(dest, n, flags);
                 ^~~~~~~~~
                 py_getrandom
msg301984 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-09-12 17:51
Oh, the warning probably comes from the fact that I upgraded since Fedora 24 to Fedora 25. Re-running ./configure fixed the issue.
History
Date User Action Args
2017-09-12 17:51:20vstinnersetstatus: open -> closed
resolution: not a bug
messages: + msg301984

stage: resolved
2017-09-12 17:41:59vstinnercreate