classification
Title: multiprocessing ppc Debian/ ia64 Ubuntu compilation error
Type: behavior Stage: resolved
Components: Extension Modules Versions: Python 3.0, Python 2.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: jnoller Nosy List: Rhamphoryncus, asksol, barry, benjamin.peterson, davin, jnoller, matejcik, ncoghlan, roudkerk
Priority: normal Keywords:

Created on 2008-06-14 19:46 by jnoller, last changed 2015-03-05 18:12 by davin. This issue is now closed.

Messages (20)
msg68211 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2008-06-14 19:46
Both debian ia64 and PPC are failing the mp test suite with the 
following error:

Re-running test 'test_multiprocessing' in verbose mode
test test_multiprocessing crashed -- <type 'exceptions.OSError'>: [Errno 
38] Function not implemented
Traceback (most recent call last):
  File "./Lib/test/regrtest.py", line 554, in runtest_inner
    indirect_test()
  File "/home/pybot/buildarea/trunk.klose-debian-
ppc/build/Lib/test/test_multiprocessing.py", line 1764, in test_main
    ProcessesMixin.pool = multiprocessing.Pool(4)
  File "/home/pybot/buildarea/trunk.klose-debian-
ppc/build/Lib/multiprocessing/__init__.py", line 226, in Pool
    return Pool(processes, initializer, initargs)
  File "/home/pybot/buildarea/trunk.klose-debian-
ppc/build/Lib/multiprocessing/pool.py", line 84, in __init__
    self._setup_queues()
  File "/home/pybot/buildarea/trunk.klose-debian-
ppc/build/Lib/multiprocessing/pool.py", line 131, in _setup_queues
    self._inqueue = SimpleQueue()
  File "/home/pybot/buildarea/trunk.klose-debian-
ppc/build/Lib/multiprocessing/queues.py", line 315, in __init__
    self._rlock = Lock()
  File "/home/pybot/buildarea/trunk.klose-debian-
ppc/build/Lib/multiprocessing/synchronize.py", line 106, in __init__
    SemLock.__init__(self, SEMAPHORE, 1, 1)
  File "/home/pybot/buildarea/trunk.klose-debian-
ppc/build/Lib/multiprocessing/synchronize.py", line 38, in __init__
    sl = self._semlock = _multiprocessing.SemLock(kind, value, maxvalue)
OSError: [Errno 38] Function not implemented
[674193 refs]
make: *** [buildbottest] Error 1
program finished with exit code 2

Buildbots:
http://www.python.org/dev/buildbot/stable/ppc%20Debian%20unstable%20trun
k/builds/1607/step-test/0
http://www.python.org/dev/buildbot/stable/ia64%20Ubuntu%20trunk/builds/1
89/step-test/0
msg68212 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2008-06-14 19:48
Sorry, should have been debian PPC and ubuntu ia64
msg68239 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2008-06-15 15:22
This is also effecting gentoo x86. After speaking with Richard, he 
suggested that this could be a side-effect if the buildbot execution is 
happening in a chroot'ed environment.

Barry, do you know if this is the case?
msg68328 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2008-06-17 15:07
I believe this is a Linux-specific problem relating to chroot jails 
missing the /dev/shm filesystem. 

I am suggesting we skip the test for now if /dev/shm does not exist, 
via:

if (sys.platform.startswith("linux"):
    if not os.path.exists("/dev/shm"):
        raise TestSkipped("Missing required /dev/shm device on Linux!")

at the top of test_multiprocessing.py

Anyone see a problem with this?
msg68334 - (view) Author: Adam Olsen (Rhamphoryncus) Date: 2008-06-17 17:29
I don't see a problem with skipping it, but if chroot is the problem,
maybe the chroot environment should be fixed to include /dev/shm?
msg68335 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2008-06-17 17:38
I agree, fixing the chroot is the long-term solution, however this gets us 
over the beta hump
msg68338 - (view) Author: Adam Olsen (Rhamphoryncus) Date: 2008-06-17 18:44
I agree with your agreement.
msg68340 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-17 20:23
Jesse, I say go ahead and make it so. I think you should make another
report thought to keep track of getting /dev/shm in the buildbot
enviroment. (Is that a buildbot bug?)
msg68349 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-17 22:44
I committed the skip in r64356. Let's sit back and watch.
msg68350 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2008-06-17 22:57
Did  you add the import and fix the syntax error

On Jun 17, 2008, at 6:44 PM, Benjamin Peterson  
<report@bugs.python.org> wrote:

>
> Benjamin Peterson <musiccomposition@gmail.com> added the comment:
>
> I committed the skip in r64356. Let's sit back and watch.
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue3111>
> _______________________________________
msg68351 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-17 23:00
1 for 2. :)
msg68352 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2008-06-17 23:08
I apologize, I should have just posted the diff

On Jun 17, 2008, at 7:00 PM, Benjamin Peterson  
<report@bugs.python.org> wrote:

>
> Benjamin Peterson <musiccomposition@gmail.com> added the comment:
>
> 1 for 2. :)
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue3111>
> _______________________________________
msg68353 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-17 23:09
On Tue, Jun 17, 2008 at 6:08 PM, Jesse Noller <report@bugs.python.org> wrote:
>
> Jesse Noller <jnoller@gmail.com> added the comment:
>
> I apologize, I should have just posted the diff

It's not your fault. I'm impatient.
msg68363 - (view) Author: Jesse Noller (jnoller) * (Python committer) Date: 2008-06-18 13:32
I switched to a more aggressive skip as it doesn't seem /dev/shm is the culprit (at least from overnight runs). I committed it in r64375 on trunk 
and I am going to wait for the build bots to run on trunk before merging.
msg70558 - (view) Author: jan matejek (matejcik) * Date: 2008-08-01 14:48
> "as it doesn't seem /dev/shm is the culprit"

Mounting /dev/shm seems to fix the problem in suse's autobuild (chroot)
environment, so for me it actually was the culprit. Perhaps you should
recheck your buildbots?
msg73206 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2008-09-14 08:55
Setting this to a release blocker, because it is affecting Neal's
automated execution of the regression test suite with a debug build.
msg73207 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2008-09-14 08:58
Scratch that - it's more likely to be Neal's setup which is at fault,
which I will be questioning on python-dev shortly (there are 3 other
tests which are failing/getting skipped in Neal's regression test suite)
msg115093 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-08-27 15:27
Can this be closed as it looks to me like a 2 year old test error and not an extension module error, am I correct?  Refer to msg68349 and msg68363.
msg115940 - (view) Author: Ask Solem (asksol) (Python committer) Date: 2010-09-09 11:34
As no one is able to confirm that this is still an issue, I'm closing it. It can be reopened if necessary.
msg237282 - (view) Author: Davin Potts (davin) * (Python committer) Date: 2015-03-05 18:12
Doing cleanup:  This was marked as out of date in 2010 but somehow escaped being marked closed.  Closing now.
History
Date User Action Args
2015-03-05 18:12:45davinsetstatus: open -> closed

nosy: + davin
messages: + msg237282

stage: resolved
2014-02-03 19:45:46BreamoreBoysetnosy: - BreamoreBoy
2010-09-09 11:34:38asksolsetresolution: out of date
messages: + msg115940
2010-08-27 15:27:11BreamoreBoysettype: behavior

messages: + msg115093
nosy: + BreamoreBoy
2010-08-27 13:50:08asksolsetnosy: + asksol
2008-09-14 08:58:57ncoghlansetpriority: release blocker -> normal
messages: + msg73207
2008-09-14 08:55:47ncoghlansetpriority: release blocker
nosy: + ncoghlan
messages: + msg73206
2008-08-01 14:48:24matejciksetnosy: + matejcik
messages: + msg70558
2008-06-18 13:32:13jnollersetmessages: + msg68363
2008-06-17 23:09:18benjamin.petersonsetmessages: + msg68353
2008-06-17 23:08:34jnollersetmessages: + msg68352
2008-06-17 23:00:39benjamin.petersonsetmessages: + msg68351
2008-06-17 22:58:02jnollersetmessages: + msg68350
2008-06-17 22:44:34benjamin.petersonsetmessages: + msg68349
2008-06-17 20:23:30benjamin.petersonsetassignee: jnoller
messages: + msg68340
2008-06-17 18:49:39Rhamphoryncussetmessages: + msg68338
2008-06-17 17:38:31jnollersetmessages: + msg68335
2008-06-17 17:29:32Rhamphoryncussetmessages: + msg68334
2008-06-17 15:07:51jnollersetnosy: + Rhamphoryncus, benjamin.peterson
messages: + msg68328
2008-06-15 15:22:55jnollersetnosy: + barry
messages: + msg68239
2008-06-14 19:48:39jnollersetmessages: + msg68212
2008-06-14 19:48:15jnollersettitle: multiprocessing pkg Debian compilation error -> multiprocessing ppc Debian/ ia64 Ubuntu compilation error
2008-06-14 19:46:47jnollercreate