classification
Title: posixpath.normpath truncating forward slashes from URL
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: govindsmenokee, serhiy.storchaka
Priority: normal Keywords:

Created on 2017-08-02 11:14 by govindsmenokee, last changed 2017-08-02 11:38 by serhiy.storchaka. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 2985 closed govindsmenokee, 2017-08-02 11:17
Messages (2)
msg299653 - (view) Author: Govind S Menokee (govindsmenokee) * Date: 2017-08-02 11:15
Handle unwanted truncation of forward slash in case of URL input for normpath function.
For Example - path = 'https://google.com'
The current output of normpath function would be - 'https:/google.com'
After changes the output would be - 'https://google.com'
msg299654 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-08-02 11:38
Is the string 'https://google.com' an URL or a path? If it is a path, posixpath.normpath() correctly collapses duplicated slashes. If it is an URL, using posixpath.normpath() is not correct.
History
Date User Action Args
2017-08-02 11:38:18serhiy.storchakasetstatus: open -> closed

nosy: + serhiy.storchaka
messages: + msg299654

resolution: not a bug
stage: resolved
2017-08-02 11:17:16govindsmenokeesetpull_requests: + pull_request3024
2017-08-02 11:15:14govindsmenokeesetmessages: + msg299653
2017-08-02 11:14:07govindsmenokeecreate