classification
Title: Add --include-py argument to Tools/msi/make_zip.py
Type: enhancement Stage: resolved
Components: Windows Versions: Python 3.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: Segev Finer, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2017-07-21 22:06 by Segev Finer, last changed 2020-05-29 09:54 by cheryl.sabella. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 2806 closed Segev Finer, 2017-07-21 22:08
Messages (3)
msg298826 - (view) Author: Segev Finer (Segev Finer) * Date: 2017-07-21 22:06
Add an argument --include-py to Tools/msi/make_zip.py that allows including the Python modules sources and not only bytecode.

I found it useful while running Twisted's test suite in PR 2318, since I got an error otherwise. I don't remember what that error was and wasn't able to reproduce it while trying to run Twisted's test suite again.
msg298852 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2017-07-22 14:13
The nuget package doesn't suffer from this - why not? Should you have been using the full layout rather than the embedding layout?
msg298853 - (view) Author: Segev Finer (Segev Finer) * Date: 2017-07-22 14:27
I used the full one. I doubt virtualenv (used by tox) will work with the embedding layout :P.

I remember getting an exception from something because it was missing the .py source files but I don't remember what it was and wasn't able to reproduce it now.
History
Date User Action Args
2020-05-29 09:54:41cheryl.sabellasetstatus: open -> closed
resolution: out of date
stage: resolved
2017-07-22 14:27:30Segev Finersetmessages: + msg298853
2017-07-22 14:13:17steve.dowersetmessages: + msg298852
2017-07-21 22:08:49Segev Finersetpull_requests: + pull_request2857
2017-07-21 22:06:13Segev Finercreate