classification
Title: test_xmlrpc_net fails
Type: behavior Stage:
Components: Tests Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, benjamin.peterson, donmez
Priority: critical Keywords:

Created on 2008-06-10 20:45 by donmez, last changed 2008-06-11 02:37 by benjamin.peterson. This issue is now closed.

Messages (7)
msg67918 - (view) Author: Ismail Donmez (donmez) * Date: 2008-06-10 20:45
Latest py3k branch,

test_xmlrpc_net
test test_xmlrpc_net failed -- Traceback (most recent call last):
  File "/Users/cartman/Sources/py3k/Lib/test/test_xmlrpc_net.py", line 
18, in test_current_time
    t0 = server.currentTime.getCurrentTime()
  File "/Users/cartman/Sources/py3k/Lib/xmlrpc/client.py", line 1095, in 
__call__
    return self.__send(self.__name, args)
  File "/Users/cartman/Sources/py3k/Lib/xmlrpc/client.py", line 1353, in 
__request
    verbose=self.__verbose
  File "/Users/cartman/Sources/py3k/Lib/xmlrpc/client.py", line 1136, in 
request
    return self._parse_response(resp, None)
  File "/Users/cartman/Sources/py3k/Lib/xmlrpc/client.py", line 1246, in 
_parse_response
    p.feed(response)
  File "/Users/cartman/Sources/py3k/Lib/xmlrpc/client.py", line 516, in 
feed
    self._parser.Parse(data, 0)
xml.parsers.expat.ExpatError: mismatched tag: line 10, column 7

This is MacOSX Leopard 10.5.3
msg67921 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-06-10 21:10
It's not a python issue: the web site at http://www.xmlrpc.com is
completely broken!

The ExpatError occurs because the returned HTML page is not strict XML.
msg67922 - (view) Author: Ismail Donmez (donmez) * Date: 2008-06-10 21:12
It is a python bug, test should use a better web page then.
msg67925 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-10 21:20
I agree. I've temporarily disabled the offending test, but we should fix
this soon.
msg67928 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-06-10 21:27
But (try a Google search) xmlrpc.com is the main site for xml-rpc resources!
What kind of site should we use for testing?
msg67929 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-10 21:28
On Tue, Jun 10, 2008 at 4:27 PM, Amaury Forgeot d'Arc
<report@bugs.python.org> wrote:
>
> Amaury Forgeot d'Arc <amauryfa@gmail.com> added the comment:
>
> But (try a Google search) xmlrpc.com is the main site for xml-rpc resources!
> What kind of site should we use for testing?

Take a look at xmlrpc.com. It seems that it is temporarily down, so we
should be back and running soon.
msg67936 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-06-11 02:37
xmlrpc.com is backup so I reenabled the test.
History
Date User Action Args
2008-06-11 02:37:40benjamin.petersonsetstatus: open -> closed
resolution: fixed
messages: + msg67936
2008-06-10 21:29:05benjamin.petersonsettitle: test_xmlrpc_net fails on Darwin -> test_xmlrpc_net fails
2008-06-10 21:28:55benjamin.petersonsetmessages: + msg67929
2008-06-10 21:27:41amaury.forgeotdarcsetmessages: + msg67928
2008-06-10 21:20:48benjamin.petersonsetpriority: release blocker -> critical
resolution: not a bug -> (no value)
messages: + msg67925
nosy: + benjamin.peterson
2008-06-10 21:12:24donmezsetmessages: + msg67922
2008-06-10 21:10:03amaury.forgeotdarcsetresolution: not a bug
messages: + msg67921
nosy: + amaury.forgeotdarc
2008-06-10 21:06:00benjamin.petersonsetpriority: release blocker
2008-06-10 20:45:59donmezsettitle: xml_rpc_net fails on Darwin -> test_xmlrpc_net fails on Darwin
2008-06-10 20:45:38donmezcreate