classification
Title: test_poplib.test_stls_context() access violation on x86 Windows7 3.6 buildbot
Type: Stage: resolved
Components: SSL, Tests, Windows Versions: Python 3.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: christian.heimes Nosy List: Lukasa, alex, christian.heimes, dstufft, janssen, paul.moore, steve.dower, tim.golden, vstinner, zach.ware
Priority: normal Keywords: buildbot

Created on 2017-06-13 10:39 by vstinner, last changed 2017-07-03 13:22 by vstinner. This issue is now closed.

Messages (3)
msg295891 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-13 10:39
test_stls_context() of test_poplib crashed with an access violation (Windows fatal exception) on x86 Windows7 3.6 buildbot. It seems like the crash occurred in OpenSSL.

http://buildbot.python.org/all/builders/x86%20Windows7%203.6/builds/417/steps/test/logs/stdio

I see 3 threads:

* Thread 0x00000a20: asyncore.loop() called from DummyPOP3Server.run(), test_poplib.py:222:

    def run(self):
        self.active = True
        self.__flag.set()
        while self.active and asyncore.socket_map:
            self.active_lock.acquire()
            asyncore.loop(timeout=0.1, count=1)   <~~~~ HERE
            self.active_lock.release()
        asyncore.close_all(ignore_all=True)

* Current thread 0x00000a5c: self._sslobj.do_handshake() <= SSLObject.do_handshake() <= DummyPOP3Handler._do_tls_handshake() <= DummyPOP3Handler.handle_read()

* Thread 0x00000360: socket.getaddrinfo() <= socket.create_connection() <= POP3._create_socket() <= POP3.__init__() <= TestPOP3Class.test_stls_context() of test_poplib.py:359


0:47:48 [207/405] test_poplib crashed
Windows fatal exception: access violation

Thread 0x00000a20 (most recent call first):
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\asyncore.py", line 144 in poll
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\asyncore.py", line 207 in loop
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\test_poplib.py", line 222 in run
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\threading.py", line 916 in _bootstrap_inner
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\threading.py", line 884 in _bootstrap

Current thread 0x00000a5c (most recent call first):
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\ssl.py", line 683 in do_handshake
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\ssl.py", line 1061 in do_handshake
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\test_poplib.py", line 172 in _do_tls_handshake
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\test_poplib.py", line 189 in handle_read
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\asyncore.py", line 423 in handle_read_event
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\asyncore.py", line 83 in read
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\asyncore.py", line 150 in poll
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\asyncore.py", line 207 in loop
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\test_poplib.py", line 222 in run
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\threading.py", line 916 in _bootstrap_inner
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\threading.py", line 884 in _bootstrap

Thread 0x00000360 (most recent call first):
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\socket.py", line 743 in getaddrinfo
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\socket.py", line 704 in create_connection
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\poplib.py", line 108 in _create_socket
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\poplib.py", line 102 in __init__
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\test_poplib.py", line 359 in test_stls_context
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\unittest\case.py", line 601 in run
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\unittest\case.py", line 649 in __call__
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\unittest\suite.py", line 122 in run
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\unittest\suite.py", line 84 in __call__
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\unittest\suite.py", line 122 in run
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\unittest\suite.py", line 84 in __call__
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\unittest\runner.py", line 176 in run
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\support\__init__.py", line 1889 in _run_suite
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\support\__init__.py", line 1923 in run_unittest
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\test_poplib.py", line 509 in test_main
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\libregrtest\runtest.py", line 165 in runtest_inner
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\libregrtest\runtest.py", line 119 in runtest
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\libregrtest\runtest_mp.py", line 71 in run_tests_slave
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\libregrtest\main.py", line 475 in _main
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\libregrtest\main.py", line 468 in main
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\libregrtest\main.py", line 532 in main
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\regrtest.py", line 46 in _main
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\test\regrtest.py", line 50 in <module>
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\runpy.py", line 85 in _run_code
  File "D:\cygwin\home\db3l\buildarea\3.6.bolen-windows7\build\lib\runpy.py", line 193 in _run_module_as_main

...
Exception: Child error on test_poplib: Exit code 3221225477
msg295892 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-06-13 10:45
@Cory: Can I have the PEP 543 right now, with a cup of tea, please? (No sugar nor milk, thank you!) :-D
msg297579 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2017-07-03 13:22
Sadly, I only saw this crash once. I don't know how to reproduce it. I close the bug since I don't expect to see it next weeks...
History
Date User Action Args
2017-07-03 13:22:16vstinnersetstatus: open -> closed
resolution: out of date
messages: + msg297579

stage: resolved
2017-06-13 10:45:23vstinnersetmessages: + msg295892
2017-06-13 10:44:30vstinnersetnosy: + Lukasa
2017-06-13 10:39:46vstinnercreate